Bug 1595643 - gdl cannot be installed if eccodes has been installed
Summary: gdl cannot be installed if eccodes has been installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdl
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1677968
TreeView+ depends on / blocked
 
Reported: 2018-06-27 09:10 UTC by Jos de Kloe
Modified: 2019-04-14 01:22 UTC (History)
3 users (show)

Fixed In Version: gdl-0.9.9-6.fc29 gdl-0.9.9-6.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-10 18:23:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Jos de Kloe 2018-06-27 09:10:41 UTC
Description of problem:

gdl cannot be installed in f28 at the same time as eccodes at the moment.
Affected versions:
  gdl-0.9.8-1
  eccodes-2.7.3
  grib_api-1.25.0-4

The problem is that eccodes obsoletes libgrib_api, which is a dependency of gdl. It must do this since it provides a collection of tools in /usr/bin that previously were provided by libgrib_api.

Upstream has decided to replace grib_api with a new project called eccodes so the logical way forward is that Fedora rebuilds dependant packages with this new library.

For your information, gdl upstream has now accepted my patch and can now be build using eccodes. See: https://github.com/gnudatalanguage/gdl/pull/390

Comment 1 Joachim Frieben 2018-08-11 10:05:25 UTC
I have the opposite problem: grib_api-1.25.0-4.fc28 cannot be updated when gdl-0.9.8-1.fc28 is installed. Run 'dnf update' and obtain

"Last metadata expiration check: 2:35:29 ago on Sat 11 Aug 2018 09:23:54 AM CEST.
Dependencies resolved.

 Problem: package gdl-0.9.8-1.fc28.x86_64 requires libgrib_api.so.1()(64bit), but none of the providers can be installed
  - package eccodes-2.7.3-1.fc28.x86_64 obsoletes grib_api < 1.26.1-1 provided by grib_api-1.25.0-4.fc28.x86_64
  - cannot install the best update candidate for package grib_api-1.25.0-4.fc28.x86_64
  - cannot install the best update candidate for package gdl-0.9.8-1.fc28.x86_64
Nothing to do.
Complete!"

Comment 2 Jos de Kloe 2018-08-11 10:34:29 UTC
correct, there is a problem caused by switching from grib_api to eccodes.
The latest attempt to build gdl to use eccodes failed.

A workaround for now would be to:
* remove eccodes
* install explicitely the latest grib_api with version number
  sudo dnf install grib_api-1.25.0
* then install gdl

I'll see what I can do to patch the gdl build to work again.

Comment 3 Joachim Frieben 2018-08-11 18:18:43 UTC
(In reply to Jos de Kloe from comment #2)
It should be sufficient to run 'dnf downgrade eccodes' followed by 'dnf install gdl'.

Comment 4 Eugene Mah 2018-11-26 10:42:09 UTC
Also happening with Fedora 29

Comment 5 Jos de Kloe 2019-02-17 15:31:35 UTC
grib_api is now dead upstream, so gdl needs to be rebuild with eccodes for those architectures that it supports.
Please take a look at the pull request I filed.
The non-supported architectures will have to keep using grib_api for now, there is no alternative.

Comment 6 Fedora Update System 2019-02-28 15:32:53 UTC
gdl-0.9.9-6.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a2e27c8343

Comment 7 Fedora Update System 2019-02-28 15:33:03 UTC
gdl-0.9.9-6.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f5af1cc27d

Comment 8 Fedora Update System 2019-03-01 22:23:16 UTC
gdl-0.9.9-6.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a2e27c8343

Comment 9 Eugene Mah 2019-03-04 11:53:48 UTC
New version installs and seems to work as it used to

Comment 10 Fedora Update System 2019-03-10 18:23:16 UTC
gdl-0.9.9-6.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-04-14 01:22:41 UTC
gdl-0.9.9-6.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.