Bug 159602 - Gnome Panel Expand issues
Gnome Panel Expand issues
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-05 12:50 EDT by Simon Goodall
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-27 10:02:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
View of panel (11.70 KB, image/png)
2005-06-05 13:11 EDT, Simon Goodall
no flags Details
Second view of panel (11.10 KB, image/png)
2005-06-05 13:12 EDT, Simon Goodall
no flags Details

  None (edit)
Description Simon Goodall 2005-06-05 12:50:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I have been using a gnome-panel with just the window list applet and the expand property set. This means that the panel expands every time i open a new window. However, I often get a problem when the panel is close to filling the width of the screen and I open a new window. This causes the panel to resize to the full width of the screen and then to a more compressed range, then back to  full width again repeatedly until I open more  windows, or close existing ones. This resulting in my CPU usage rocketing making the system sluggish very quickly.
e.g. opening a window causing this problem will take several seconds before a prompt becomes available.
This does not happen all the time, so it seems to depend on what the size of the panel is before the new window is added. However, if it does happen, then i close a window (e.g. a gnome-term) then start it back up, the problem disappears and reappears.

Version-Release number of selected component (if applicable):
gnome-panel-2.8.1-3

How reproducible:
Sometimes

Steps to Reproduce:
1. Create a gnome-panel with expand set and only the window list applet (I opened it across the top)
2. Open several windows until the panel is the width of the screen
3. panel cannot determine what size to be
  

Actual Results:  The panel switches from being fully expanded to compressed very quickly using a large amount of CPU to do so.

Expected Results:  The panel should choose one size to be and stick with it.

Additional info:

This is an issue I have had intermittently since I first created a separate gnome-panel. approx 6 months+  ago
Comment 1 Simon Goodall 2005-06-05 13:11:41 EDT
Created attachment 115155 [details]
View of panel

A view of the panel when its resizing
Comment 2 Simon Goodall 2005-06-05 13:12:29 EDT
Created attachment 115156 [details]
Second view of panel

Another view of the panel resizing
Comment 3 Mark McLoughlin 2005-06-22 11:44:01 EDT
Do you still see the problem with FC4? I can't reproduce here ..
Comment 4 Simon Goodall 2005-07-15 13:29:06 EDT
I have upgraded to fc4 and been running it for a week or so now. I have not
encountered the problem so far and so would appear to be fixed. It seemed to
happen quite regularly in fc3.

Note You need to log in before you can comment on or make changes to this bug.