Bug 1596020 - Introduce database group profile
Summary: Introduce database group profile
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1596076 1597506
TreeView+ depends on / blocked
 
Reported: 2018-06-28 05:04 UTC by Atin Mukherjee
Modified: 2018-10-23 15:12 UTC (History)
2 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1596076 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:12:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1512691 0 high CLOSED PostgreSQL DB Restore: unexpected data beyond EOF 2021-02-22 00:41:40 UTC

Internal Links: 1512691

Description Atin Mukherjee 2018-06-28 05:04:29 UTC
Description of problem:

Running DB workload patterns with all perf xlators enabled as default has resulted into some inconsistency issues. Based on the internal testing done by Elvir Kuric there're certain set of perf xlators which need to be turned off to get these types of workload supported by Gluster.

The proposal is to leverage group profile infrastructure to group together all those tunables at one place so that users just need to apply the profile to the volume to use it for the data base workload.

Version-Release number of selected component (if applicable):
mainline

Comment 1 Worker Ant 2018-06-28 08:27:36 UTC
REVIEW: https://review.gluster.org/20414 (extras/group : add database workload profile) posted (#1) for review on master by Atin Mukherjee

Comment 2 Atin Mukherjee 2018-06-28 10:41:52 UTC
There's some effort going on at BZ https://bugzilla.redhat.com/show_bug.cgi?id=1512691 to address the current gaps in the performance xlators where these issues are seen. Once those problems are addressed, the group profile may not be no longer required.

Comment 4 Atin Mukherjee 2018-06-28 13:28:06 UTC
This is what Elko updated:


Environment

    Openshift Container Platform - 3.7
    Openshift Container Platform - 3.9
    Red Hat Gluster Storage-3.X

Issue

    The pgbench perf benchmark for PGSQL does not complete
    Issue with open-behind and write-behind xlators in Red Hat Gluster Storage when gluster-file is being used for containerized DB workload.

Resolution

    Adapt performance translators per below recommendation in Red Hat Gluster Storage / CNS

    Follow the steps below to adapt performance translators

Note : In case of Container Native Storage (CNS), below commands should be be executed inside one CNS pod

 # gluster volume set VOLUME performance.open-behind off
 # gluster volume set VOLUME performance.write-behind off
 # gluster volume set VOLUME performance.stat-prefetch off 
 # gluster volume set VOLUME  performance.quick-read off 
 # gluster volume set VOLUME performance.strict-o-direct on 
 # gluster volume set VOLUME  performance.read-ahead off
 # gluster volume set VOLUME performance.io-cache off
 # gluster volume set VOLUME performance.readdir-ahead off

Comment 5 Worker Ant 2018-06-28 17:18:48 UTC
COMMIT: https://review.gluster.org/20414 committed in master by "Niels de Vos" <ndevos@redhat.com> with a commit message- extras/group : add database workload profile

Running DB workload patterns with all perf xlators enabled as default has
resulted into some inconsistency issues. Based on the internal testing done by
Elko Kuric (ekuric@redhat.com) there're certain set of perf xlators which need
to be turned off to get these types of workload supported by Gluster.

The proposal is to leverage group profile infrastructure to group together all
those tunables at one place so that users just need to apply the profile to the
volume to use it for the data base workload.

Credits : Elko Kuric (ekuric@redhat.com)

Change-Id: I8a50e915278ad4085b9aaa3f160a33af7c0b0444
fixes: bz#1596020
Signed-off-by: Atin Mukherjee <amukherj@redhat.com>

Comment 7 Shyamsundar 2018-10-23 15:12:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.