Bug 1596168 - ipa help topics displays 'ipa: ERROR: an internal error has occurred'
Summary: ipa help topics displays 'ipa: ERROR: an internal error has occurred'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-28 11:22 UTC by Sudhir Menon
Modified: 2018-10-30 10:59 UTC (History)
7 users (show)

Fixed In Version: ipa-4.6.4-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:58:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3187 None None None 2018-10-30 10:59:43 UTC

Description Sudhir Menon 2018-06-28 11:22:37 UTC
Description of problem: ipa help topics displays 'ipa: ERROR: an internal error has occurred'

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux Server release 7.6 Beta (Maipo)
ipa-server-4.6.4-1.el7.x86_64
389-ds-base-1.3.8.2-1.el7.x86_64
certmonger-0.78.4-6.el7.x86_64
sssd-1.16.2-1.el7.x86_64
krb5-server-1.15.1-32.el7.x86_64
pki-ca-10.5.9-1.el7.noarch
pki-server-10.5.9-1.el7.noarch
certmonger-0.78.4-6.el7.x86_64

How reproducible:Always

Steps to Reproduce:
1. Install IPA server
2. kinit admin
3. ipa help topics

Actual results:

[root@master ~]# klist -l
Principal name                 Cache name
--------------                 ----------
admin@IPATEST.TEST             KEYRING:persistent:0:0
[root@master ~]# ipa help topics
ipa: DEBUG: importing all plugin modules in ipaclient.remote_plugins.schema$3c83e1a5...
ipa: DEBUG: importing plugin module ipaclient.remote_plugins.schema$3c83e1a5.plugins
ipa: DEBUG: importing all plugin modules in ipaclient.plugins...
ipa: DEBUG: importing plugin module ipaclient.plugins.automember
ipa: DEBUG: importing plugin module ipaclient.plugins.automount
ipa: DEBUG: importing plugin module ipaclient.plugins.ca
ipa: DEBUG: importing plugin module ipaclient.plugins.cert
ipa: DEBUG: importing plugin module ipaclient.plugins.certmap
ipa: DEBUG: importing plugin module ipaclient.plugins.certprofile
ipa: DEBUG: importing plugin module ipaclient.plugins.csrgen
ipa: DEBUG: importing plugin module ipaclient.plugins.dns
ipa: DEBUG: importing plugin module ipaclient.plugins.hbacrule
ipa: DEBUG: importing plugin module ipaclient.plugins.hbactest
ipa: DEBUG: importing plugin module ipaclient.plugins.host
ipa: DEBUG: importing plugin module ipaclient.plugins.idrange
ipa: DEBUG: importing plugin module ipaclient.plugins.internal
ipa: DEBUG: importing plugin module ipaclient.plugins.location
ipa: DEBUG: importing plugin module ipaclient.plugins.migration
ipa: DEBUG: importing plugin module ipaclient.plugins.misc
ipa: DEBUG: importing plugin module ipaclient.plugins.otptoken
ipa: DEBUG: importing plugin module ipaclient.plugins.otptoken_yubikey
ipa: DEBUG: importing plugin module ipaclient.plugins.passwd
ipa: DEBUG: importing plugin module ipaclient.plugins.permission
ipa: DEBUG: importing plugin module ipaclient.plugins.rpcclient
ipa: DEBUG: importing plugin module ipaclient.plugins.server
ipa: DEBUG: importing plugin module ipaclient.plugins.service
ipa: DEBUG: importing plugin module ipaclient.plugins.sudorule
ipa: DEBUG: importing plugin module ipaclient.plugins.topology
ipa: DEBUG: importing plugin module ipaclient.plugins.trust
ipa: DEBUG: importing plugin module ipaclient.plugins.user
ipa: DEBUG: importing plugin module ipaclient.plugins.vault
ipa: DEBUG: raw: help(u'topics', version=u'2.229')
ipa: DEBUG: help(u'topics', version=u'2.229')
ipa: ERROR: non-public: AssertionError: 
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ipalib/backend.py", line 141, in execute
    return self.Command[_name](*args, **options)
  File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 450, in __call__
    return self.__do_call(*args, **options)
  File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 478, in __do_call
    ret = self.run(*args, **options)
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 830, in run
    self.print_topics(outfile)
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 861, in print_topics
    to_cli(t).ljust(self._mtl), topic[0]))
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 75, in to_cli
    assert isinstance(name, str)
AssertionError
ipa: ERROR: an internal error has occurred

[root@master ~]# ipa help hbac
  hbacsvcgroup  HBAC Service Groups
  hbacsvc       HBAC Services
  hbacrule      Host-based access control

[root@master ~]# ipa help sudo
  sudorule      Sudo Rules
  sudocmdgroup  Groups of Sudo Commands
  sudocmd       Sudo Commands


Expected results:
Should display all help commands.

Additional info:

Comment 3 Florence Blanc-Renaud 2018-07-10 05:06:26 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/7626

Comment 6 msiddiqu 2018-08-16 06:34:24 UTC
Tested on Red Hat Enterprise Linux Server release 7.6 Beta (Maipo) 
IPA server version: ipa-server-4.6.4-5.el7.x86_64

The issue mentioned in the bug is no more being reproduced, therefore marking it as verified.

Version-Release number of other selected components (if applicable):
389-ds-base-1.3.8.4-10.el7.x86_64
certmonger-0.78.4-9.el7.x86_64
sssd-1.16.2-12.el7.x86_64
krb5-server-1.15.1-34.el7.x86_64
pki-ca-10.5.9-5.el7.noarch
pki-server-10.5.9-5.el7.noarch
selinux-policy-3.13.1-215.el7.noarch


Actual Results: 

[root@master ~]# ipa help topics
automember         Auto Membership Rule.
automount          Automount
ca                 Manage Certificate Authorities
caacl              Manage CA ACL rules.
cert               IPA certificate operations
certmap            Certificate Identity Mapping
certprofile        Manage Certificate Profiles
config             Server configuration
delegation         Group to Group Delegation
dns                Domain Name System (DNS)
domainlevel        Raise the IPA Domain Level.
group              Groups of users
hbac               Host-based access control commands
hbactest           Simulate use of Host-based access controls
host               Hosts/Machines
hostgroup          Groups of hosts.
idrange            ID ranges
idviews            ID Views
krbtpolicy         Kerberos ticket policy
location           IPA locations
migration          Migration to IPA
misc               Misc plug-ins
netgroup           Netgroups
otp                One time password commands
passwd             Set a user's password
permission         Permissions
ping               Ping the remote IPA server to ensure it is running.
pkinit             Kerberos PKINIT feature status reporting tools.
privilege          Privileges
pwpolicy           Password policy
radiusproxy        RADIUS Proxy Servers
realmdomains       Realm domains
role               Roles
schema             API Schema
selfservice        Self-service Permissions
selinuxusermap     SELinux User Mapping
server             IPA servers
serverrole         IPA server roles
service            Services
servicedelegation  Service Constrained Delegation
stageuser          Stageusers
sudo               commands for controlling sudo configuration
topology           Topology
trust              Cross-realm trusts
user               Users
vault              Vaults

[root@master ~]# ipa help sudo
  sudorule      Sudo Rules
  sudocmdgroup  Groups of Sudo Commands
  sudocmd       Sudo Commands

[root@master ~]# ipa help hbac
  hbacsvcgroup  HBAC Service Groups
  hbacsvc       HBAC Services
  hbacrule      Host-based access control

Comment 7 Sudhir Menon 2018-08-16 06:36:28 UTC
Marking the bug as VERIFIED.

Comment 9 errata-xmlrpc 2018-10-30 10:58:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3187


Note You need to log in before you can comment on or make changes to this bug.