Bug 1596208 - XDR files contain illegal "long" integer declarations.
Summary: XDR files contain illegal "long" integer declarations.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1596206
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-28 12:23 UTC by Niels de Vos
Modified: 2018-10-08 17:44 UTC (History)
3 users (show)

Fixed In Version: glusterfs-4.1.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-08 17:44:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2018-06-28 12:23:40 UTC
+++ This bug was initially created as a clone of Bug #1596188 +++

Description of problem:

With some toolchains (latest buildroot for example) the rpcgen rejects to process the rpc/xdr/src/changelog-xdr.x file, because it contains "unsigned long" integer declarations. Looking at the standard, long is not supported in XDR: https://tools.ietf.org/html/rfc4506#section-4.2


Version-Release number of selected component (if applicable):


How reproducible:
Compile gluster with buildroot 2018.05.

Actual results:

------------------------------------
Making all in rpc/xdr/gen
       unsigned long seq;
^^^^^^^^^^^^^^^^^^^^^^^^
changelog-xdr.x, line 30: expected ';'
Makefile:562: recipe for target 'changelog-xdr.h' failed
make[5]: *** [changelog-xdr.h] Error 1
------------------------------------

Expected results:

Compilation without error.

Additional info:

fix attached


Note You need to log in before you can comment on or make changes to this bug.