Bug 159647 - Authentication Errors in
Authentication Errors in
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-06 11:08 EDT by Derek J. Balling
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-15 14:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek J. Balling 2005-06-06 11:08:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I get the following messages every 30 minutes in /var/log/cron. This bug seems extremely similar to a problem reported in atd (#150131).

Jun  5 04:30:01 sedp1 crond[28457]: Authentication service cannot retrieve authentication info.
Jun  5 05:00:01 sedp1 crond[28471]: Authentication service cannot retrieve authentication info.
Jun  5 05:30:01 sedp1 crond[28508]: Authentication service cannot retrieve authentication info.
Jun  5 06:00:01 sedp1 crond[28522]: Authentication service cannot retrieve authentication info.

Version-Release number of selected component (if applicable):
vixie-cron-4.1-33_FC3

How reproducible:
Always

Steps to Reproduce:
1. Wait 30 minutes for crond to put an error message automagically in the log.

Additional info:
Comment 1 Jason Vas Dias 2005-06-06 12:18:58 EDT
Please supply some further information:
1. Do you have SELinux disabled / enabled / enforcing / permissive ?
2. Has SELinux ever been enabled on the machine ?
3. Have you modified the cron initscript to run cron in a chroot
   or as a non-root user ?
4. What cron job runs every half hour - is it run for a NIS / LDAP
   or normal user ?
5. Have you modified the default /etc/pam.d/crond file ? If so ,
   please append it to this bug report.
Thank you!
Comment 2 Derek J. Balling 2005-06-06 12:22:16 EDT
1.) It is is presently disabled.
2.) Unknown. On some of our boxes it was disabled at the outset, in
some of them I had to remember to disable it after the fact.
3.) No. I haven't modified the cron initscript at all.
4.) Has to be a normal user. We have no NIS/LDAP users.
5.) No. It is the stock /etc/pam.d/crond as supplied by
vixie-cron-4.1-33_FC3.
Comment 3 Jason Vas Dias 2005-06-07 15:14:01 EDT
I am not able to reproduce this problem.

Please answer the following questions:
1. What version of PAM are you running (rpm -q pam) ?
2. What version of SELinux are you running (rpm -q libselinux) ?
3. What is the cron job command that causes these messages ?
   There is no cron job that runs every half hour installed by 
   default.
   If you don't know which job it is, please gather the data:
   # tar -cpf - /var/spool/cron /var/log/cron /etc/cron.d /etc/crontab   | gzip
> /tmp/cron.tar.gz
   and attach the /tmp/cron.tar.gz file to this bug. 
4. Can you reproduce the problem with a cron job run every minute
   by the root user ? Eg, as root:
   # echo '* * * * * /bin/date>/tmp/cron.root.test' \   
     >/var/spool/cron/root
   Then do the messages appear in the log every minute?

   If so, then please gather strace information :
   # strace -tvfp `pidof crond` > /tmp/crond.strace.log 2>&1 &
   and wait for one of the messages to be emitted to /var/log/cron; 
   then:
   # pkill strace; gzip /tmp/crond.strace.log
   and append the /tmp/crond.strace.log.gz file to this bug report.

   If it is not reproducible with a command run every minute as 
   root, please try to reproduce with a command run every minute as
   non-root user, gathering the strace log as above.

Thank you!
Comment 4 Jason Vas Dias 2005-06-15 14:42:15 EDT
I have verified that this problem is not reproducible with the 
default PAM and CRON configuration shipped. 
It is possible that PAM may be misconfigured in some way as to
cause this problem, but without the further information requested,
I am unable to determine what this might be.
Hence, this bug is being closed.
If it is still a problem for you, please reopen and supply the 
further information requested in previous comment - thanks.

Note You need to log in before you can comment on or make changes to this bug.