Bug 1596563 - SELinux prevents chronyc from accessing nscd socket
Summary: SELinux prevents chronyc from accessing nscd socket
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.5
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-29 09:03 UTC by Zdenek Pytela
Modified: 2018-10-30 10:06 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.13.1-207.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:05:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
ausearch -i -m avc,user_avc,selinux_err,user_selinux_err -ts recent (3.35 KB, text/x-vhdl)
2018-06-29 09:03 UTC, Zdenek Pytela
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3509301 None None None 2018-06-29 09:25:34 UTC
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:06:24 UTC

Description Zdenek Pytela 2018-06-29 09:03:12 UTC
Created attachment 1455481 [details]
ausearch -i -m avc,user_avc,selinux_err,user_selinux_err -ts recent

Description of problem:
SELinux prevents chronyc from accessing nscd socket

Version-Release number of selected component (if applicable):
chrony-3.2-2.el7.x86_64
selinux-policy-3.13.1-192.el7_5.3.noarch

How reproducible:
always

Steps to Reproduce:
1. Install and start nscd
2. Execute chronyc tracking

Actual results:
AVCs and USER_AVCs are triggered

Expected results:
No AVC

Additional info:
In my scenario, the "chronyc tracking" command show the output correctly, just prevents from using the advantages of nscd

Comment 10 errata-xmlrpc 2018-10-30 10:05:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.