Bug 1596852 - XDG_DATA_DIRS is not set by the Firefox 60.1.0 wrapper
Summary: XDG_DATA_DIRS is not set by the Firefox 60.1.0 wrapper
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox
Version: 6.10
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jan Horak
QA Contact: Desktop QE
Lucie Maňásková
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-29 19:22 UTC by Paul
Modified: 2018-07-18 13:55 UTC (History)
28 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the Firefox application terminated unexpectedly when attempting to display the file download dialog. With this update, the XDG_DATA_DIRS variable has been set correctly. As a result, showing the file dialog now works as expected.
Clone Of:
Environment:
Last Closed: 2018-07-18 13:54:57 UTC


Attachments (Terms of Use)
GTK3 schema patch for Firefox 60 (351 bytes, patch)
2018-06-29 19:22 UTC, Paul
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2218 None None None 2018-07-18 13:55:07 UTC
Mozilla Foundation 1474326 None None None 2019-03-28 16:45:37 UTC
Red Hat Knowledge Base (Solution) 3516111 None None None 2018-07-03 18:47:33 UTC

Description Paul 2018-06-29 19:22:16 UTC
Created attachment 1455568 [details]
GTK3 schema patch for Firefox 60

Description of problem: Some window prompts (such as "Browse...") cause Firefox 60ESR to crash as it cannot find a gsettings schema.


Version-Release number of selected component (if applicable):
firefox-60.1.0-5.el6.x86_64


How reproducible:
Every time. 


Steps to Reproduce:
1. Open Firefox 60 ESR on RHEL6
2. Browse to any page that has an attachment or browse button (such as this one, "Add an attachment")
3. Click Browse/Attach

Actual results:
Firefox Crashes


Expected results:
Firefox displays a GTK3 file system window


Additional info:

I have a "patch" that adds the env declaration to the launch wrapper. See the attachment.

Comment 2 Paul 2018-06-29 19:25:23 UTC
Terminal output during the crash:

(firefox:30405): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap (core dumped)

Comment 3 Martin Stransky 2018-07-02 06:21:47 UTC
Jan, can you please look at it? Thanks.

Comment 4 Paul 2018-07-03 12:51:27 UTC
This happens with any GTK3 file browse window, so we have come across an easier way to reproduce this.

1. Open Firefox 60.1.0 on RHEL6
2. File -> Open File...

Comment 7 masanari iida 2018-07-04 08:26:14 UTC
I have encountered this symptom on my local test box.

The OS was installed from RHEL6.8 DVD sometimes ago,
and I have updated firefox 60 RPM and dependencies.

firefox-60.1.0-5.el6
nspr-4.19.0-1.el6
nss-3.36.0-8.el6
nss-sysinit-3.36.0-8.el6
nss-tools-3.36.0-8.el6
nss-utils-3.36.0-1.el6

I can reproduce the crash 10 times in 10 tests.
From top Menu,  File -> open
or 
Right Click on a link -> Select "save as"

reason (collected by abrt)
Process /usr/lib64/firefox/firefox was killed by signal 5 (SIGTRAP)

In messages,
kernel: firefox[3351] trap int3 ip:7f60a73eb5bf sp:7ffdf728e2f0 error:0

Comment 8 masanari iida 2018-07-04 08:48:35 UTC
Apply the patch on this BZ case, it resolved the issue for me.
In order to double check, I removed the patch and the symptom come back again.

Comment 10 Joe Wright 2018-07-09 15:20:44 UTC
Occurs with both 32 and 64 bit versions

Comment 12 Jean Redfearn 2018-07-09 19:02:30 UTC
The patch did not change anything on our systems (RHEL6.10 with gtk2).
We also see segfault from libzul.so in /var/log/messages

Comment 14 Jan Horak 2018-07-11 07:00:44 UTC
(In reply to Jean Redfearn from comment #12)
> The patch did not change anything on our systems (RHEL6.10 with gtk2).
> We also see segfault from libzul.so in /var/log/messages
You might be hitting different issue, please file a new bug for it or use customer portal to report it. 

If you wish you can attach a stack trace to the new bug by:
debuginfo-install firefox
firefox -g
run
(wait for crash)
backtrace

Comment 15 Michael Boisvert 2018-07-11 15:37:10 UTC
I can confirm using the reproducers in the bug description and comment 4, that an appropriate GTK3 file browse window successfully pops up when issuing various browse, add attachment or file open commands in firefox-60.1.0-6.el6.

Comment 16 Akemi Yagi 2018-07-12 22:48:17 UTC
I, too, can confirm that the provided patch fixes the issue.

Comment 17 Pavel Kankovsky 2018-07-16 16:12:56 UTC
XDG_DATA_DIRS should probably be set to something like "$MOZ_LIB_DIR/firefox/bundled/share:${XDG_DATA_DIRS:-/usr/share}".

XDG_DATA_DIRS="$MOZ_LIB_DIR/firefox/bundled/share" (that is without any reference to standard data dirs) seems to break external viewers such as Evince. FF is unwilling to run them (or even to offer to run them) and when you convince FF to start them, they are likely to fail anyway.

Comment 20 errata-xmlrpc 2018-07-18 13:54:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2218


Note You need to log in before you can comment on or make changes to this bug.