Bug 1596865 - Update to GParted 0.31.0 in EL6 and EPEL7
Summary: Update to GParted 0.31.0 in EL6 and EPEL7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: gparted
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-29 20:19 UTC by Mike Fleetwood
Modified: 2018-09-06 03:43 UTC (History)
1 user (show)

Fixed In Version: gparted-0.31.0-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-06 03:43:31 UTC
Type: Bug


Attachments (Terms of Use)
gparted launched from menu (123.69 KB, image/png)
2018-07-10 22:32 UTC, Mukundan Ragavan
no flags Details

Description Mike Fleetwood 2018-06-29 20:19:30 UTC
Please update GParted from 0.19.1 to the latest, 0.31.0, in EL6 and
EPEL7.  This is mostly about getting current code in the hands of the
users with incremental improvements.  The GParted UI has not changed and
there are no incompatible changes.

Notable improvements:
* Unpartitioned drive read-write support
* GPT partition naming
* Recognise NVME devices
* Partial LUKS read-write support
  (No support for creating, opening, closing or formatting LUKS
  encrypted volumes.  However file systems inside open LUKS volumes can
  be copied, resized and manipulated and closed LUKS volumes can be
  moved).
* Fix a number of rare crashes

Blkid was upgraded to a mandatory requrement.

I believe that this is inline with the EPEL policy which allows upstream
upgrades of middle version numbers when there are no incompatibilities.
http://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies#A_little_bit_bigger_minor_version_updates

Thanks,
Mike Fleetwood (GParted Developer)

Comment 1 Mukundan Ragavan 2018-06-30 21:06:29 UTC
coming up! :)

Comment 2 Fedora Update System 2018-07-09 02:07:45 UTC
gparted-0.31.0-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-b0d388c572

Comment 3 Mike Fleetwood 2018-07-10 10:11:49 UTC
Just using the same .spec file from Fedora 27/28 on EPEL 7 has
some issues because of the differences between the OSs.  (I assumed you
would start from the existing EPEL 7 .spec file and update as required).

First issue I encountered is that GParted fails to launch from the
GParted menu icon.

Comment 4 Mukundan Ragavan 2018-07-10 22:32:55 UTC
Created attachment 1457937 [details]
gparted launched from menu

I saw you -1 karma on bodhi and tried to launch gparted from my centos install. I cannot reproduce this at all.

I have (1) upgrading from 0.19 (currently in epel), (2) installing gparted afresh. I  have done both these in a new centos install and my current centos vm.

Additionally, I have launched from command line and from menu - both under xfce and GNOME.

I am able to luanch gparted in all these situations.

Comment 5 Mukundan Ragavan 2018-07-10 22:33:44 UTC
can you launch from the terminal and see if some error shows up? I need more information on how to reproduce this.

Comment 6 Mike Fleetwood 2018-07-11 19:49:35 UTC
Sorry about the lack of details.  I had a second PolKit action file
named /usr/share/polkit-1/actions/org.gnome.gparted.local.policy which
was for /usr/local/bin/gparted in addition to the one installed by the
latest gparted-0.31.0-4.el7 package.  This appeared to be confusing
PolKit resulting in the allow_gui setting not working, so the DISPLAY
environment variable was not being carried through pkexec, hence gparted
was failing with:
  (gpartedbin:9622): Gtk-WARNING **: cannot open display:

Removed that second PolKit action file and I can now run GParted from
the GUI menu and the command line.

Comment 7 Fedora Update System 2018-07-11 19:50:37 UTC
gparted-0.31.0-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-b0d388c572

Comment 8 Mike Fleetwood 2018-07-11 19:53:05 UTC
I have looked at the .spec file and see a couple of issues:

* configure uses --enable-online-resize flag

  Normally this flag shouldn't be used because the configure script will
  automatically set this when (lib)parted >= 3.2 is found, which
  includes online resize support.  However bug #1423357 [1] back ported
  the online resize change [2] into parted 3.1-29.el7 [3].

  I specifically install previous parted-3.1-28 and ran new
  gparted-0.31.0-4.  It allows online resize to be requested but fails
  when implemented.

  Therefore gparted package must depend on parted >= 3.1-29.  Suggest
  a comment in the .spec file why --enable-online-resize flag can be
  used.

  [1] https://bugzilla.redhat.com/show_bug.cgi?id=1423357
  [2] http://git.savannah.gnu.org/cgit/parted.git/commit/?id=f09ca967a0bc443b869a6fad5b5ffe8e95c3fe9a
  [3] parted changelog
      2017-08-10 - Brian C. Lane <bcl@redhat.com> - 3.1-29
      - Add support for NVMe devices
      Resolves: rhbz#1316239
      - Backport partition resize command
      Resolves: rhbz#1423357


* configure uses --enable-xhost-root flag

  This is intended as a workaround for running GParted on Wayland.  It
  uses xhost to grant root access to the users X11 display session.
  This is unnecessary on EPEL which sets up XAUTHORITY environment
  variable and xauth file.

  Should remove --enable-xhost-root configure flag.


Otherwise GParted works well and the LVM PV shrinking bug is fixed.

Comment 9 Mukundan Ragavan 2018-07-12 01:10:00 UTC
Mike, thanks for the comments.

I have edited the EPEL7 update. please test it.

Comment 10 Fedora Update System 2018-07-12 01:11:38 UTC
gparted-0.31.0-4.el7.1 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-b0d388c572

Comment 11 Fedora Update System 2018-07-12 14:44:56 UTC
gparted-0.31.0-4.el7.1 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-b0d388c572

Comment 12 Mike Fleetwood 2018-07-12 16:14:19 UTC
All looks good now.

* Confirmed that upgrading to gparted-0.31.0-4.el7.1 upgrades to
  parted-3.1-29.el7 as a dependency.

* Confirmed that gparted shell wrapper no longer unnecessarily uses
  xhost to add root as an X display authorised user.
  - Can still run GParted from the GUI menu.
  - Can still run GParted from the command line both as normal user and
    root.

Comment 13 Mike Fleetwood 2018-07-29 12:21:02 UTC
I have just submitted the following pull request:
* Update to GParted 0.31.0 in EL6
  https://src.fedoraproject.org/rpms/gparted/pull-request/2

Tested and confirmed GParted launches and works as expected from the
desktop menu item and from the command line as normal user and root.

Thanks,
Mike

Comment 14 Fedora Update System 2018-07-30 02:06:04 UTC
gparted-0.31.0-4.el7.1 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Mike Fleetwood 2018-08-15 14:56:44 UTC
Can the above pull request for GParted 0.31.0 in EL6 be reviewed please.
Thanks,
Mike

Comment 16 Mukundan Ragavan 2018-08-15 23:16:31 UTC
 Sorry for the delay. I will do this in the coming day or two.

Comment 17 Fedora Update System 2018-08-18 15:52:42 UTC
gparted-0.31.0-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-76e0c098f5

Comment 18 Fedora Update System 2018-08-19 17:03:46 UTC
gparted-0.31.0-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-76e0c098f5

Comment 19 Fedora Update System 2018-09-06 03:43:31 UTC
gparted-0.31.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.