Bug 159713 - Admin server will not start
Admin server will not start
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
7.1
sparcv9 Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-07 08:52 EDT by Don Pandori
Modified: 2015-12-07 12:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:18:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Pandori 2005-06-07 08:52:45 EDT
Description of problem:


Version-Release number of selected component (if applicable):
DS 7.1 - Admin Server Netscape-Enterprise/6.2 B04/18/2005 12:20

How reproducible: every time


Steps to Reproduce:
1. cd $INSTALL
2. ./start-admin
3.
  
Actual results: Admin server does not start. (See messages below)



Expected results: Admin server start.


Additional info:

Log information - 
[07/Jun/2005:08:33:50] info ( 2400): successful server startup
[07/Jun/2005:08:33:50] info ( 2400): Netscape-Enterprise/6.2 B04/18/2005 12:20
[07/Jun/2005:08:33:51] info ( 2400): Access Host filter is: *.oft-dom.nyenet
[07/Jun/2005:08:33:51] info ( 2400): Access Address filter is: *
[07/Jun/2005:08:33:51] failure ( 2400): Configuration initialization failed: 
Error running init function load-modules: dlopen 
of /ns/fedora/servers/bin/https/lib/libNSServletPlugin.so failed (ld.so.1: ns-
httpd: fatal: libjvm.so: open failed: No such file or directory)

I went through and found libjvm.so and added the directory to my 
LD_LIBRARY_PATH, no error message this time, but no admin server starts.
Comment 1 Rich Megginson 2005-06-07 11:26:13 EDT
You should not need to set LD_LIBRARY_PATH - it should automatically find the
jvm under bin/base/jre.  There is probably some other environment setting that
is interfering with the script.  I'm assuming this is on Solaris.  Solaris9?  32
bit or 64 bit?  Can you dump your environment variables and attach the output to
this bug?  Please obscure any sensitive data first.
Comment 2 Don Pandori 2005-06-07 12:03:17 EDT
Solaris 9, 9/04, 64-bit

I added a set -x to the start-admin script...

[root@donunix /ns/fedora/servers] ./start-admin
SERVER_ROOT=/ns/fedora/servers
PRODUCT_NAME=https
PRODUCT_BIN=uxwdog
PRODUCT_SUBDIR=/ns/fedora/servers/admin-serv
LD_LIBRARY_PATH=/ns/fedora/servers/bin/https/lib:/ns/fedora/servers/lib:
+ export LD_LIBRARY_PATH 
+ test -r /ns/fedora/servers/bin/https/bin/start-jvm 
+ . /ns/fedora/servers/bin/https/bin/start-jvm 
NSES_JRE=/ns/fedora/servers/bin/base/jre
+ export NSES_JRE 
NSES_SERVER_HOME=/ns/fedora/servers
+ export NSES_SERVER_HOME 
NSES_JRE_RUNTIME_LIBPATH=/ns/fedora/servers/bin/base/jre/lib/sparc/client:/ns/f
edora/servers/bin/base/jre/lib/sparc/native_
threads:/ns/fedora/servers/bin/base/jre/lib/sparc:/ns/fedora/servers/lib/jss
+ export NSES_JRE_RUNTIME_LIBPATH 
NSES_CLASSPATH=/ns/fedora/servers/bin/https/jar/NSServletLayer.jar:/ns/fedora/s
ervers/bin/https/jar/NSJavaUtil.jar:/ns/fedo
ra/servers/bin/https/jar/NSJavaMiscUtil.jar:/ns/fedora/servers/bin/https/jar/se
rvlet.jar:/ns/fedora/servers/bin/https/jar/s
ervlet-2.3-filters-
api.jar:/ns/fedora/servers/bin/https/jar/jaxp.jar:/ns/fedora/servers/bin/https/
jar/crimson.jar:/ns/fedor
a/servers/bin/https/jar/xalan.jar:/ns/fedora/servers/bin/https/jar/jspengine.ja
r:/ns/fedora/servers/bin/https/jar/jakarta-n
aming.jar:/ns/fedora/servers/java/ldapjdk.jar:/ns/fedora/servers/java/jss3.jar
+ export NSES_CLASSPATH 
LD_LIBRARY_PATH=/ns/fedora/servers/bin/base/jre/lib/sparc/client:/ns/fedora/ser
vers/bin/base/jre/lib/sparc/native_threads:/
ns/fedora/servers/bin/base/jre/lib/sparc:/ns/fedora/servers/lib/jss:/ns/fedora/
servers/bin/https/lib:/ns/fedora/servers/lib
:
+ export LD_LIBRARY_PATH 
LIBPATH=/ns/fedora/servers/bin/base/jre/lib/sparc/client:/ns/fedora/servers/bin
/base/jre/lib/sparc/native_threads:/ns/fedor
a/servers/bin/base/jre/lib/sparc:/ns/fedora/servers/lib/jss:/ns/fedora/servers/
bin/https/lib:/ns/fedora/servers/lib:::/usr/
threads/lib:/usr/ibmcxx/lib:/usr/lib:/lib
+ export LIBPATH 
SHLIB_PATH=/ns/fedora/servers/bin/base/jre/lib/sparc/client:/ns/fedora/servers/
bin/base/jre/lib/sparc/native_threads:/ns/fe
dora/servers/bin/base/jre/lib/sparc:/ns/fedora/servers/lib/jss:/ns/fedora/serve
rs/bin/https/lib:/ns/fedora/servers/lib::
+ export SHLIB_PATH 
NS_SERVER_HOME=/ns/fedora/servers
+ export NS_SERVER_HOME 
NS_HTTPS_HOME=/ns/fedora/servers/bin/https
+ export NS_HTTPS_HOME 
PATH=/ns/fedora/servers/bin/https/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/openwi
n/bin:/usr/dt/bin:/usr/sfw/bin:/usr/local/bi
n
+ export PATH 
+ cd /ns/fedora/servers/bin/https/bin 
+ [ 0 -eq 0 ] 
arg=-start
+ ./uxwdog -d /ns/fedora/servers/admin-serv/config 
Netscape-Enterprise/6.2 B04/18/2005 12:20
+ test 1 -ne 0 
+ exit 1 

Here's my environment:

[root@donunix /ns/fedora/servers] env
PWD=/ns/fedora/servers
TZ=US/Eastern
HZ=
HOSTNAME=donunix
PS1=[\u@\h \w] 
VISUAL=vi
MACHTYPE=sparc-sun-solaris2.9
MAIL=/var/mail/root
OLDPWD=/ns/fedora/servers/admin-serv
EDITOR=vi
LOGNAME=root
SHLVL=1
SHELL=/sbin/sh
HOSTTYPE=sparc
OSTYPE=solaris2.9
HOME=/
TERM=xterm
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/openwin/bin:/usr/dt/bin:/usr/sfw/bin:/u
sr/local/bin
_=/bin/env

This is the resulting error:

[07/Jun/2005:11:57:27] info ( 2445): successful server startup
[07/Jun/2005:11:57:27] info ( 2445): Netscape-Enterprise/6.2 B04/18/2005 12:20
[07/Jun/2005:11:57:28] info ( 2445): Access Host filter is: *.oft-dom.nyenet
[07/Jun/2005:11:57:28] info ( 2445): Access Address filter is: *
[07/Jun/2005:11:57:28] failure ( 2445): Configuration initialization failed: 
Error running init function load-modules: dlopen 
of /ns/fedora/servers/bin/https/lib/libNSServletPlugin.so failed (ld.so.1: ns-
httpd: fatal: libjvm.so: open failed: No such file or directory)

Comment 3 Rich Megginson 2005-06-08 10:46:56 EDT
When you ran the setup program, it asked you for the location of the JRE.  We
rely on JRE version 1.4.2_05 or later on Solaris.  What JRE did you use?  Did it
install properly under serverroot/bin/base/jre?  This is what I see under the
server root on my Solaris 9 64 bit installation:
find . -name libjvm\* -print
./bin/base/jre/lib/sparc/server/libjvm.so
./bin/base/jre/lib/sparc/client/libjvm.so
./bin/base/jre/lib/sparc/libjvm.so
Comment 4 Don Pandori 2005-06-08 11:35:31 EDT
I'm running 1.4.2_08 on my machine with the 64-bit extensions installed.  I 
told the installer to use /usr/java (which is a symlink to /usr/j2se) as the 
base.  The contents of the resulting nsjre.zip file is:

[root@donunix /var/tmp/FEDORA/base] unzip -l nsjre.zip 
Archive:  nsjre.zip
 Length    Date    Time    Name
 ------    ----    ----    ----
      0  06-07-05  16:04   bin/
      0  06-07-05  16:04   bin/base/
      0  06-07-05  16:04   bin/base/jre/
      0  06-07-05  16:04   bin/base/jre/bin/
  78880  06-07-05  16:04   bin/base/jre/bin/java
  62556  06-07-05  16:04   bin/base/jre/bin/keytool
  62692  06-07-05  16:04   bin/base/jre/bin/orbd
  62576  06-07-05  16:04   bin/base/jre/bin/policytool
  62556  06-07-05  16:04   bin/base/jre/bin/rmid
  62560  06-07-05  16:04   bin/base/jre/bin/rmiregistry
  62564  06-07-05  16:04   bin/base/jre/bin/servertool
  62572  06-07-05  16:04   bin/base/jre/bin/tnameserv
   1080  06-07-05  16:04   bin/base/jre/bin/HtmlConverter
  62548  06-07-05  16:04   bin/base/jre/bin/appletviewer
  62556  06-07-05  16:04   bin/base/jre/bin/extcheck
  62568  06-07-05  16:04   bin/base/jre/bin/idlj
  62548  06-07-05  16:04   bin/base/jre/bin/jar
  62560  06-07-05  16:04   bin/base/jre/bin/jarsigner
   1789  06-07-05  16:04   bin/base/jre/bin/java-rmi.cgi
  62556  06-07-05  16:04   bin/base/jre/bin/javac
  62556  06-07-05  16:04   bin/base/jre/bin/javadoc
  62544  06-07-05  16:04   bin/base/jre/bin/javah
  62552  06-07-05  16:04   bin/base/jre/bin/javap
  62552  06-07-05  16:04   bin/base/jre/bin/jdb
  62556  06-07-05  16:04   bin/base/jre/bin/native2ascii
  62548  06-07-05  16:04   bin/base/jre/bin/rmic
  62560  06-07-05  16:04   bin/base/jre/bin/serialver
      0  06-07-05  16:04   bin/base/jre/bin/sparcv9/
  87136  06-07-05  16:04   bin/base/jre/bin/sparcv9/java
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/keytool
  71328  06-07-05  16:04   bin/base/jre/bin/sparcv9/orbd
  71192  06-07-05  16:04   bin/base/jre/bin/sparcv9/policytool
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/rmid
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/rmiregistry
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/servertool
  71184  06-07-05  16:04   bin/base/jre/bin/sparcv9/tnameserv
  71160  06-07-05  16:04   bin/base/jre/bin/sparcv9/appletviewer
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/extcheck
  71184  06-07-05  16:04   bin/base/jre/bin/sparcv9/idlj
  71168  06-07-05  16:04   bin/base/jre/bin/sparcv9/jar
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/jarsigner
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/javac
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/javadoc
  71160  06-07-05  16:04   bin/base/jre/bin/sparcv9/javah
  71168  06-07-05  16:04   bin/base/jre/bin/sparcv9/javap
  71168  06-07-05  16:04   bin/base/jre/bin/sparcv9/jdb
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/native2ascii
  71168  06-07-05  16:04   bin/base/jre/bin/sparcv9/rmic
  71176  06-07-05  16:04   bin/base/jre/bin/sparcv9/serialver
      0  06-07-05  16:04   bin/base/jre/lib/
 138980  06-07-05  16:04   bin/base/jre/lib/dt.jar
1193789  06-07-05  16:04   bin/base/jre/lib/htmlconverter.jar
  18381  06-07-05  16:04   bin/base/jre/lib/ir.idl
    429  06-07-05  16:04   bin/base/jre/lib/orb.idl
5093185  06-07-05  16:04   bin/base/jre/lib/tools.jar
 ------                    -------
9288569                    55 files

I know the files are installed:

[dpandori@donunix /usr] find ./j2se -name libjvm\* -print
./j2se/jre/lib/sparc/client/libjvm.so
./j2se/jre/lib/sparc/libjvm.so
./j2se/jre/lib/sparc/server/libjvm.so
./j2se/jre/lib/sparcv9/server/libjvm.so
[dpandori@donunix /usr] 

It looks like whatever is creating the archive is getting confused for some 
reason.
Comment 5 Rich Megginson 2005-06-08 11:53:38 EDT
It looks like the bug is in setup.  Either it doesn't like the symlink, or it
doesn't like the 64 bit extensions.  We've never tested it with the native 64
bit version of java because we include some 32 bit apps that need the 32 bit
version.  I would recommend trying it with the 32 bit version of Java.
Comment 6 Don Pandori 2005-06-08 12:02:13 EDT
I found the problem.

I have the SDK installed and gave the top level path to the SDK not the JRE. 
(I'm not sure why Sun's packages are designed this way, but they are)  I gave 
the installer /usr/j2se/jre and that took care of the problem.  Perhaps a 
check in setup.pl to verify that there are some *.so files in the lib 
directory, etc. to make sure that you have a good JRE would be a good thing.  
If I come up with the code for it, where do you want me to mail it to?

Thanks!
Comment 8 Rich Megginson 2005-12-01 12:05:49 EST
Fixed in FDS 1.0
Comment 9 Anh Nguyen 2007-11-29 18:18:16 EST
Verified.
go to brandywine
Install DS80
start idm-console
console started OK

Note You need to log in before you can comment on or make changes to this bug.