Bug 15973 - initlog doesn't start properly chrooted named
initlog doesn't start properly chrooted named
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 25269 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-10 23:40 EDT by Need Real Name
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-15 15:55:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-10 23:40:38 EDT
I want to run named chrooted, but I cannot start through
/etc/rc.d/init.d/named. This is a slave named, and at most only one
named-xfer succeeds. The commandline within /etc/rc.d/init.d/named is

daemon /home/chroot/named/usr/sbin/named -u named -g named -t
/home/chroot/named -c /named.conf

In syslog, for each failed named-xfer, I see a signal 13 (SIGPIPE).
If I start named from the commandline (without nice and initlog), then it
runs fine and all of the named-xfers succeed. I tracked down the problem to
initlog. If I start the command

initlog -c "/home/chroot/.../named -u named ..."

Then I have the same problem. However, if instead of -c I use -r, then
named will start properly. As a side note, the -q switch is not documented
in the man page. ;-)

Solution? For named, just start with the -r switch. Unfortunately I
couldn't really understand the difference between -c and -r and I don't
know what else it would do.

Thank you for your time, Vilmos Soti
Comment 1 Bill Nottingham 2000-08-11 09:47:40 EDT
-c runs the command and logs its output.

-r runs the command, and initlog stays around looking
for things to log on its own stdin. Presumably what's
happening is that bind is closing its stdin, so initlog
exits.
Comment 2 Bill Nottingham 2001-01-30 15:35:04 EST
*** Bug 25269 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2001-01-30 15:59:58 EST
(make that, bind is closing its stdout and stderr.)
Comment 4 Bill Nottingham 2001-01-31 12:45:48 EST
*** Bug 25269 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2005-02-15 15:55:13 EST
Closing out bugs on older, no longer supported, releases.

initlog is no longer in the current devel tree, so it is unlikely to change.

Note You need to log in before you can comment on or make changes to this bug.