Bug 1597473 - introduce cluster.daemon-log-level option
Summary: introduce cluster.daemon-log-level option
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1597509 1597511
TreeView+ depends on / blocked
 
Reported: 2018-07-03 02:26 UTC by Atin Mukherjee
Modified: 2018-10-23 15:12 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1597509 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:12:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2018-07-03 02:26:54 UTC
Description of problem:

As of now we have a client-log-level option which can be applied per volume basis. However this gets applied on all the clients and is not an global option. In a scaled setup where there are too many new volume requests coming in, daemons like shd get restarted on every volume start which can bloat the shd logs significantly. Users might need a global tuning which can help in logging in a particular log level for all the node level daemon services (excluding bricks).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-07-03 02:29:21 UTC
REVIEW: https://review.gluster.org/20442 (glusterd: Introduce daemon-log-level cluster wide option) posted (#2) for review on master by Atin Mukherjee

Comment 2 Worker Ant 2018-07-03 14:30:04 UTC
COMMIT: https://review.gluster.org/20442 committed in master by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- glusterd: Introduce daemon-log-level cluster wide option

This option, applicable to the node level daemons can be very helpful in
controlling the log level of these services. Please note any daemon
which is started prior to setting the specific value of this option (if
not INFO) will need to go through a restart to have this change into
effect.

Change-Id: I7f6d2620bab2b094c737f5cc816bc093e9c9c4c9
fixes: bz#1597473
Signed-off-by: Atin Mukherjee <amukherj@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:12:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.