Bug 1597565 - SpamAssassin failure on idn_dots.t regression test
Summary: SpamAssassin failure on idn_dots.t regression test
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: perl
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: perl-maint-list
QA Contact: BaseOS QE - Apps
URL: https://bz.apache.org/SpamAssassin/sh...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-03 08:45 UTC by Giovanni Bechis
Modified: 2019-11-21 15:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-21 15:03:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Giovanni Bechis 2018-07-03 08:45:05 UTC
Description of problem:
On upcoming 3.4.2 SpamAssassin idn_dots.t regression test fails only on RH systems.
Rebuilding an updated perl from src is a workaround.

How reproducible:
The problem appears on Rhel6, Rhel7 and the corresponding CentOS releases.

Steps to Reproduce:
svn checkout https://svn.apache.org/repos/asf/spamassassin/branches/3.4
cd 3.4
perl Makefile.PL
make
prove -v t/idn_dots.t
Actual results:
Regression test fails

Expected results:
Regression test passes

Additional info:
The regression test pass on:
Ubuntu Trusty, Perl 5.18.2-2ubuntu1.6
Ubuntu Xenial, Perl 5.22.1-9ubuntu0.5
MacOS X 10.6.8, Perl 5.26.2 (MacPorts build)
MacOS X 10.6.8, Perl v5.10.0 (Apple build)
MacOS X 10.11.6, Perl 5.26.2 (MacPorts build)
CentOS 7.5.1804, Perl 5.18.4 (Perl.org source, default build config)
CentOS 7.5.1804, Perl 5.28.0 (Perl.org source, default build config)
Fedora Core 27, Perl 5.26.2-406.fc27
OpenBSD 6.3, Perl 5.24.3

Comment 2 Giovanni Bechis 2018-07-03 08:46:24 UTC
Additional info on SpamAssassin bz: https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7591

Comment 3 Petr Pisar 2018-07-03 09:01:55 UTC
Could you please extract the failing code and paste/attach it here so that the issue can be reproduced without the SpamAssasin code base? My first impression is that it's an bug fixed in a Perl version later then 5.16.3 that you did not hit on MacOS X because RHEL builds packages with hardening compiler flags that can make some bugs visible.

If you need a help with minimizing the test, please contact Red Hat support.

Comment 5 Giovanni Bechis 2018-07-03 09:09:17 UTC
The regression test is working on "MacOS X 10.6.8, Perl v5.10.0 (Apple build)",
Anyway I will try to find a way to reproduce the problem using less code.

Comment 6 Giovanni Bechis 2018-07-03 09:25:29 UTC
I will also try a src-rpm build without hardening compiler flags to catch the error, thanks for the suggestion.

Comment 7 Giovanni Bechis 2018-07-11 18:20:13 UTC
Test passes on CentOS 7.5 with perl 5.16 built from src.rpm (with all RH patches) but with -D_FORTIFY_SOURCE=0.
This is definitely a Perl bug that has been fixed in later Perl versions.

Comment 10 Petr Pisar 2019-11-21 15:03:18 UTC
Red Hat does not plan to fix this issue in Red Hat Enterprise Linux 7. If this issue is critical for your use case please contact Red Hat support service.
We also recommend you trying Red Hat Enterprise Linux 8 that delivers Perl 5.26 and that could contain the missing fix. However, I'm unable to verify it since there was no isolated reproducer provided.


Note You need to log in before you can comment on or make changes to this bug.