Bug 159770 - xmgrace PS output fails
xmgrace PS output fails
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-07 17:04 EDT by Hai Ah Nam
Modified: 2008-02-11 19:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 19:25:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hai Ah Nam 2005-06-07 17:04:33 EDT
Description of problem:
My postscript files will no longer print (I get a blank page) when using
XMGrace.  All other applications print fine.  Before the recent update to
foomatic-3.0.2-13.4 it worked fine.  Should I remove the new version and install
the older version of foomatic?  Is that the only fix?  If yes, then can you
point me to some directions on how to uninstall foomatic (I've been looking but
can't find anything that actually works on fedora).

Version-Release number of selected component (if applicable):
grace-5.1.18
foomatic-3.0.2-13.4
Printer - Canon i450 (using driver for BJC-7000) since Canon i450 not provided

How reproducible:
Only with XMGrace application.  But if I make the .ps file from grace and open
the file with ggv and try to print I still get a blank page.  I can however
print a jpeg produced from grace.  

Steps to Reproduce:
1.Make graph on XMGrace
2.Print using PS Level 2 to device (lp -c)
3.Prints blank page
  
Actual results:
Prints blank page

Expected results:
Print graph seen on the screen

Additional info:
I am under the assumption that it is foomatic causing this issue from the advice
of a xmgrace forum user.  If it is not foomatic, could you point me in the right
direction as to why I can print pages fine for all applications except xmgrace?

Thanks!
Comment 1 Tim Waugh 2005-06-08 04:10:55 EDT
Hi,

1. You have put 'test3' as the product version, but I think you must mean '3' as
in Fedora Core 3 -- can you please confirm that you are using Fedora Core 3?  If
fc4test3 there is a separate version for that.

2. Please attach the output of 'printconf-tui --Xexport', making sure to remove
any passwords it may contain.  Also please let me know the name of the print
queue you are printing to.
Comment 2 Hai Ah Nam 2005-06-08 13:40:46 EDT
Tim,

Thanks for the prompt reply.  Yes I did mean Fedora Core 3 (excuse me, I'm new
to this).

I was finally able to uninstall foomatic-3.0.2-13.4 and installed an older
version and now everything seems to be working fine.  Another colleague who just
installed Fedora Core 3 had other printing issues and I gave him the same
advice.  It also worked for him.

Perhaps the new version of foomatic is lacking.
Comment 3 Tim Waugh 2005-06-08 18:05:53 EDT
Well, I'd rather find the problem and fix it than just have everyone downgrade. :-)

Which older version did you install?
Comment 4 Hai Ah Nam 2005-06-08 18:20:20 EDT
Yeah, I was hoping for a better fix to the problem, but my necessity to print
has driven me to this option.  I used

foomatic-3.0.2-3.i386.rpm

Just in case anyone else doesn't know about uninstalling foomatic (which was me
a day ago), this is what I wrote at the command line

rpm -e --nodeps foomatic-3.0.2-13.4
rpm -i foomatic-3.0.2-3.i386.rpm 
(of course after downloading the old version of foomatic)

Thanks!
Comment 5 Tim Waugh 2005-06-09 05:02:24 EDT
Please supply:

1. a PS file that demonstrates the problem
2. the output of 'printconf-tui --Xexport'

Thanks.
Comment 6 Hai Ah Nam 2005-06-09 14:50:14 EDT
Do you know I had to reinstall the bad foomatic :) - but if it helps to solving
the problem I guess it's worth the trouble.

The PS file can be found at:
http://www-rohan.sdsu.edu/~azar/printertest.ps
(it will open using ggv for fedora - you should see a histogram - try to print
it - it will only print a blank page)


The output for printconf-tui --Xexport is:
  <id NAME="local" SERIAL="1117825669">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        <_i450-2 ATOMIC="TRUE" TYPE="LIST">
          <alias_list ANONYMOUS="TRUE" TYPE="LIST">
            </alias_list>
          <queue_type TYPE="STRING" VALUE="LOCAL"/>
          <queue_data TYPE="LIST">
            <local_printer_device TYPE="STRING" VALUE="/dev/usb/lp0"/>
            </queue_data>
          <filter_data TYPE="LIST">
            <print_header_page TYPE="BOOL" VALUE="FALSE"/>
            <flags TYPE="LIST">
              <send_FF TYPE="BOOL" VALUE="FALSE"/>
              <convert_text_to_Postscript TYPE="BOOL" VALUE="TRUE"/>
              <rerender_Postscript TYPE="BOOL" VALUE="FALSE"/>
              <assume_data_is_text TYPE="BOOL" VALUE="FALSE"/>
              <send_EOT TYPE="BOOL" VALUE="FALSE"/>
              </flags>
            <mf_type TYPE="STRING" VALUE="MFOMATIC"/>
            <filter_locale TYPE="STRING" VALUE="C"/>
            <printer_id TYPE="STRING" VALUE="Canon-BJC-7000"/>
            <gs_driver TYPE="STRING" VALUE="gimp-print-ijs"/>
            <foomatic_defaults ANONYMOUS="TRUE" TYPE="LIST">
              <option_default TYPE="LIST">
                <name TYPE="STRING" VALUE="PageSize"/>
                <type TYPE="STRING" VALUE="enum"/>
                <default TYPE="STRING" VALUE="Letter"/>
                </option_default>
              </foomatic_defaults>
            </filter_data>
          <filter_type TYPE="STRING" VALUE="MAGICFILTER"/>
          <queue_description TYPE="STRING" VALUE=""/>
          <jobsheets TYPE="LIST">
            <start TYPE="STRING" VALUE="none"/>
            <end TYPE="STRING" VALUE="none"/>
            </jobsheets>
          <margins TYPE="LIST">
            <top TYPE="INT" VALUE="36"/>
            <right TYPE="INT" VALUE="36"/>
            <bottom TYPE="INT" VALUE="36"/>
            <left TYPE="INT" VALUE="36"/>
            </margins>
          <lpoptions TYPE="LIST">
            <cpi TYPE="STRING" VALUE="12"/>
            <lpi TYPE="STRING" VALUE="7"/>
            <page-bottom TYPE="STRING" VALUE="86"/>
            <page-left TYPE="STRING" VALUE="57"/>
            <page-right TYPE="STRING" VALUE="57"/>
            <page-top TYPE="STRING" VALUE="72"/>
            <scaling TYPE="STRING" VALUE="100"/>
            <wrap TYPE="STRING" VALUE="true"/>
            </lpoptions>
          </_i450-2>
        </print_queues>
      <sharing_globals TYPE="LIST">
        <browsing TYPE="BOOL" VALUE="TRUE"/>
        </sharing_globals>
      </printconf>
    </datatree>
  </adm_context>

Comment 7 Tom Wood 2005-10-05 11:06:55 EDT
Also experiencing the same problem with xmgrace 5.1.18 on FC4 fully updated.
Comment 8 Matthew Miller 2006-07-10 17:12:48 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 9 petrosyan 2008-02-11 19:25:41 EST
Fedora Core 3 is not maintained anymore.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.

Note You need to log in before you can comment on or make changes to this bug.