Bug 1597776 - br-state-check.t crashed while brick multiplex is enabled
Summary: br-state-check.t crashed while brick multiplex is enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: changelog
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1597768
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-03 15:19 UTC by Mohit Agrawal
Modified: 2018-10-23 15:12 UTC (History)
5 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1597768
Environment:
Last Closed: 2018-10-23 15:12:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2018-07-04 02:18:18 UTC
REVIEW: https://review.gluster.org/20132 (changelog: fix br-state-check.t crash for brick_mux) posted (#4) for review on master by MOHIT AGRAWAL

Comment 2 Worker Ant 2018-07-05 09:36:42 UTC
REVIEW: https://review.gluster.org/20132 (changelog: fix br-state-check.t crash for brick_mux) posted (#5) for review on master by MOHIT AGRAWAL

Comment 3 Worker Ant 2018-07-11 03:12:14 UTC
COMMIT: https://review.gluster.org/20132 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- changelog: fix br-state-check.t crash for brick_mux

Problem: br-state-check.t is getting crash

Solution: Check condition in rpcsvc_request_create
          before allocate memory from rxpool

BUG: 1597776
Change-Id: I4fde1ade6073f603c32453f1840395db9a9155b7
fixes: bz#1597776
Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>

Comment 4 Shyamsundar 2018-10-23 15:12:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.