Bug 1598403 - The GNU C Library version 2.28
Summary: The GNU C Library version 2.28
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carlos O'Donell
QA Contact:
URL:
Whiteboard: ChangeAcceptedF29,SystemWideChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-05 10:58 UTC by Jan Kurik
Modified: 2018-11-30 17:04 UTC (History)
3 users (show)

Fixed In Version: glibc-2.28-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 17:04:46 UTC


Attachments (Terms of Use)

Description Jan Kurik 2018-07-05 10:58:46 UTC
This is a tracking bug for Change: The GNU C Library version 2.28
For more details, see: https://fedoraproject.org/wiki/Changes/GLIBC228

Switch glibc in Fedora 29 to glibc version 2.28.

Comment 1 Adam Williamson 2018-08-07 16:54:27 UTC
I *think* this has been 'testable' since 2018-03-01, hasn't it, since we've been on upstream git snapshots (2.27.9000) since then?

Comment 2 Carlos O'Donell 2018-08-07 17:39:30 UTC
(In reply to Adam Williamson from comment #1)
> I *think* this has been 'testable' since 2018-03-01, hasn't it, since we've
> been on upstream git snapshots (2.27.9000) since then?

We consider testable when we switch to the stable release, which we have already done. Thanks for the reminder!

Comment 3 Jan Kurik 2018-08-14 11:22:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 4 Leslie Satenstein 2018-09-01 12:32:26 UTC
Is the "/usr/bin/strip" program part of the gcc update for F29?  

strip version from F28 shrinks a file from, for example, 41640 bytes to  35248.

With the F29 beta that same 41640 file shrinks to roughly 39k. 

Modules from gcc 8.2 after strip are 4 k larger than the version associated with gcc 8.1

Comment 5 Leslie Satenstein 2018-10-18 13:59:04 UTC
Hi Jan
can this be marked as a duplicate of 1623218

Comment 6 Ben Cotton 2018-11-30 17:04:46 UTC
This Change appears to have been implemented for Fedora 29. If it is not closed, please let me know so I can re-open it against Rawhide.


Note You need to log in before you can comment on or make changes to this bug.