Bug 1598406 - OpenShift Origin 3.11
Summary: OpenShift Origin 3.11
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Čajka
QA Contact:
URL:
Whiteboard: ChangeAcceptedF29,SelfContainedChange
Keywords:
Depends On: 1608505
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-05 11:08 UTC by Jan Kurik
Modified: 2018-11-30 17:04 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-11-30 17:04:34 UTC


Attachments (Terms of Use)

Description Jan Kurik 2018-07-05 11:08:50 UTC
This is a tracking bug for Change: OpenShift Origin 3.10 
For more details, see: https://fedoraproject.org/wiki/Changes/origin3.10

Rebase of the Openshift Origin package to the latest upstream version, along with introduction of necessary infrastructure container images.

Comment 1 Jan Kurik 2018-08-14 11:17:12 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Joe Doss 2018-08-26 22:31:11 UTC
origin-node-3.10.0-1.fc29 is currently broken with 

/usr/bin/openshift-node-config: No such file or directory

Building the RPM from a5e4ac9 includes the missing /usr/bin/openshift-node-config binary.

Comment 3 Jakub Čajka 2018-08-28 13:22:40 UTC
(In reply to Joe Doss from comment #2)
> origin-node-3.10.0-1.fc29 is currently broken with 
> 
> /usr/bin/openshift-node-config: No such file or directory
> 
> Building the RPM from a5e4ac9 includes the missing
> /usr/bin/openshift-node-config binary.

Could you elaborate what the issue is or what are you seeing. There is also bug BZ#1622150 for f28/3.9 opened that I believe is same issue. Looking in to is now.

Comment 4 Ben Cotton 2018-08-28 13:53:52 UTC
Today is the '100% code complete deadline' Change Checkpoint[1], meaning that Fedora 29 Changes must now be code complete. All the code required to enable to the new change should now be finished. If your Change is code complete, please update the status of this tracker back to "ON_QA". The change does not have to be fully tested by this deadline.

We have now reached the Beta freeze. If your Change is not code complete, you need to request a Freeze Exception[2] or invoke the contingency plan.

[1] https://fedoraproject.org/wiki/Changes/Policy#Beta_deadline.2Faccepted_changes_100.25_complete

[2] https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

Comment 5 Joe Doss 2018-08-28 14:43:18 UTC
(In reply to Jakub Čajka from comment #3)
> (In reply to Joe Doss from comment #2)
> > origin-node-3.10.0-1.fc29 is currently broken with 
> > 
> > /usr/bin/openshift-node-config: No such file or directory
> > 
> > Building the RPM from a5e4ac9 includes the missing
> > /usr/bin/openshift-node-config binary.
> 
> Could you elaborate what the issue is or what are you seeing. There is also
> bug BZ#1622150 for f28/3.9 opened that I believe is same issue. Looking in
> to is now.

That looks like the same issue. /usr/bin/openshift-node-config is totally missing from the current RPM that is on koji. Building a new RPM from openshift-ansible (a5e4ac9 is what I used) creates an RPM that provides /usr/bin/openshift-node-config and fixes my issue.

Comment 6 Jakub Čajka 2018-08-29 13:40:31 UTC
Up mentioned issue should be fixed in origin-3.10.0-2.fc30 and origin-3.10.0-2.fc29. As we are in beta freeze this will take some time to propagate, if it is critical for you please open separate BZ and apply for exception.
The binary have not been packaged, thanks for the report.

Comment 7 Jakub Čajka 2018-10-02 10:25:06 UTC
Due to the issue described in BZ#1608505 and with approval from FESCO(see change tracking issue https://pagure.io/fesco/issue/1927) origin will be rebased to version 3.11.

Comment 8 Ben Cotton 2018-11-30 17:04:34 UTC
This Change appears to have been implemented for Fedora 29. If it is not closed, please let me know so I can re-open it against Rawhide.


Note You need to log in before you can comment on or make changes to this bug.