Bug 1598483 - rkward 0.6.5 is incompatible with R 3.5.0
Summary: rkward 0.6.5 is incompatible with R 3.5.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rkward
Version: 27
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Pierre-YvesChibon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-05 15:36 UTC by martin
Modified: 2018-10-16 12:08 UTC (History)
3 users (show)

Fixed In Version: 28 rkward-0.7.0-3.fc28 rkward-0.7.0-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-27 02:33:53 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 396206 None None None 2018-07-05 15:36:04 UTC

Description martin 2018-07-05 15:36:05 UTC
Description of problem:

the R backend unrecoverably crashes at startup of rkward



Version-Release number of selected component (if applicable):
0.6.5

How reproducible:
always

Steps to Reproduce:
1. start rkward
2.
3.

Actual results: crash ; application is unusable


Expected results: application starts with working backend


Additional info:

rkward 0.6.5 is incompatible with R >= 3.5.0
it is necessary to upgrade to rkward 0.7.0.
cf https://bugs.kde.org/show_bug.cgi?id=396206

Comment 1 martin 2018-07-09 21:26:22 UTC
ping?

This is a regression that does not exist upstream.

Rkward 0.7. appears to build fine in rawhide, and it works flawlessly in debian testing/buster.

Why do you keep broken 0.6.5 in the Fedora 28 stable branch?

Comment 2 Fedora Update System 2018-07-10 18:05:47 UTC
rkward-0.7.0-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b351cd2225

Comment 3 Fedora Update System 2018-07-11 23:42:56 UTC
rkward-0.7.0-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b351cd2225

Comment 4 Fedora Update System 2018-09-14 18:57:00 UTC
rkward-0.7.0-3.fc28 rpy-2.9.4-4.fc28 R-3.5.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ec2d348730

Comment 5 Fedora Update System 2018-09-14 23:49:37 UTC
R-3.5.1-1.fc28, rkward-0.7.0-3.fc28, rpy-2.9.4-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ec2d348730

Comment 6 Kevin Kofler 2018-09-24 23:21:48 UTC
An update is still required for Fedora 27! Rkward has not been working at all anymore since https://bodhi.fedoraproject.org/updates/FEDORA-2018-b11015006b

Comment 7 Kevin Kofler 2018-09-24 23:47:06 UTC
Scratch build against R 3.5.0 that works for me for now:
https://koji.fedoraproject.org/koji/taskinfo?taskID=29869476
but now R 3.5.1 is queued for stable, so Rkward 0.7.0 should probably be built against that one instead. It is not currently in the build root though.

Comment 8 Fedora Update System 2018-09-25 03:26:52 UTC
R-3.5.1-1.fc27 rkward-0.7.0-3.fc27 rpy-2.8.6-8.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf4ad16022

Comment 9 Fedora Update System 2018-09-25 03:27:02 UTC
R-3.5.1-1.fc27 rkward-0.7.0-3.fc27 rpy-2.8.6-8.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf4ad16022

Comment 10 Fedora Update System 2018-09-27 02:33:53 UTC
R-3.5.1-1.fc28, rkward-0.7.0-3.fc28, rpy-2.9.4-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-09-27 03:37:30 UTC
R-3.5.1-1.fc27, rkward-0.7.0-3.fc27, rpy-2.8.6-8.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf4ad16022

Comment 12 Fedora Update System 2018-10-16 12:08:15 UTC
R-3.5.1-1.fc27, rkward-0.7.0-3.fc27, rpy-2.8.6-8.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.