Bug 159849 - Problems will (badly formed?) Content-Disposition HTTP header
Problems will (badly formed?) Content-Disposition HTTP header
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-08 12:58 EDT by Mark McLoughlin
Modified: 2007-12-20 11:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:46:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2005-06-08 12:58:05 EDT
If you try and download an attachment whose filename contains a space from yahoo
mail, firefox gets confused, basically.

e.g.

  - Mail contains "Tax Assignment.doc"
  - Click on link, download dialog tries to save/open a file called "Tax"
  - OpenOffice.org refuses to open it (but that's another bug)

A little bit of debugging shows that yahoo is returning:

  Content-Disposition: attachment; filename=Tax Assignment.doc\r\n

whereas gmail returns

  Content-Disposition: attachment; filename="Tax Assignment.doc"\r\n

It works fine with gmail, so I'm assuming this is the problem.

Not sure if yahoo is even being spec compliant, but it seems like something that
would be straightforward to work around and would save a lot of annoyance for
people.
Comment 1 Mark McLoughlin 2005-06-08 13:03:48 EDT
(This is firefix-1.0.4-2 by the way)
Comment 2 Matěj Cepl 2007-12-20 11:46:50 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.