Bug 1598506 - SELinux prevents NetworkManager from mmap()-ing /usr/sbin/dnsmasq
Summary: SELinux prevents NetworkManager from mmap()-ing /usr/sbin/dnsmasq
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-05 16:07 UTC by Martin Pitt
Modified: 2018-10-30 10:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:06:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:06:40 UTC

Description Martin Pitt 2018-07-05 16:07:33 UTC
Description of problem: When NetworkManager runs dnsmasq on current RHEL 7.6 nightlies, the following SELinux error appears:

type=1400 audit(1530806620.255:4): avc:  denied  { map } for  pid=2269 comm="dnsmasq" path="/usr/sbin/dnsmasq" dev="dm-0" ino=714988 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:dnsmasq_exec_t:s0 tclass=file permissive=0

Version-Release number of selected component (if applicable):


How reproducible: Always (with Cockpit's check-networking-settings integration test)


Additional info: This has never been seen on any other operating system (Fedora 27/28, RHEL 7.5, CentOS 7, RHEL 8, etc.), it happens *only* on RHEL 7.6.

Comment 2 Martin Pitt 2018-07-05 16:08:50 UTC
Whoops, forgot the package versions:

selinux-policy-targeted-3.13.1-207.el7.noarch
selinux-policy-3.13.1-207.el7.noarch
NetworkManager-1.12.0-1.el7.x86_64
dnsmasq-2.76-7.el7.x86_64
libselinux-2.5-13.el7.x86_64

Comment 3 Lukas Vrabec 2018-07-20 10:27:15 UTC

*** This bug has been marked as a duplicate of bug 1460322 ***

Comment 6 errata-xmlrpc 2018-10-30 10:06:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.