Bug 1599010 - [abrt] dnf: _build_group(): comps.py:249:_build_group:ValueError: no group 'hawaii-desktop' from environment 'basic-desktop-environment'
Summary: [abrt] dnf: _build_group(): comps.py:249:_build_group:ValueError: no group 'h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:9cebf8a8bcba3d8846d080fb4dd...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-07 22:41 UTC by Paul DeStefano
Modified: 2019-08-31 01:38 UTC (History)
7 users (show)

Fixed In Version: dnf-4.2.5-4.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-31 01:38:45 UTC


Attachments (Terms of Use)
File: _var_log_dnf.log (339.22 KB, text/plain)
2018-07-07 22:41 UTC, Paul DeStefano
no flags Details
File: backtrace (2.09 KB, text/plain)
2018-07-07 22:41 UTC, Paul DeStefano
no flags Details
File: cgroup (331 bytes, text/plain)
2018-07-07 22:41 UTC, Paul DeStefano
no flags Details
File: cpuinfo (1.13 KB, text/plain)
2018-07-07 22:41 UTC, Paul DeStefano
no flags Details
File: dnf-makecache.log (75.81 KB, text/plain)
2018-07-07 22:41 UTC, Paul DeStefano
no flags Details
File: environ (2.46 KB, text/plain)
2018-07-07 22:41 UTC, Paul DeStefano
no flags Details
File: mountinfo (4.03 KB, text/plain)
2018-07-07 22:41 UTC, Paul DeStefano
no flags Details
File: namespaces (129 bytes, text/plain)
2018-07-07 22:41 UTC, Paul DeStefano
no flags Details
File: open_fds (490 bytes, text/plain)
2018-07-07 22:41 UTC, Paul DeStefano
no flags Details

Description Paul DeStefano 2018-07-07 22:41:26 UTC
Description of problem:
Just tried to install Basic Desktop group with dnf

Version-Release number of selected component:
dnf-3.0.1-1.fc29

Additional info:
reporter:       libreport-2.9.5
cmdline:        /usr/bin/python3 /bin/dnf groups install 'Basic Desktop'
crash_function: _build_group
exception_type: ValueError
executable:     /bin/dnf
interpreter:    python3-3.6.5-4.fc29.x86_64
kernel:         4.18.0-0.rc2.git4.1.fc29.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
comps.py:249:_build_group:ValueError: no group 'hawaii-desktop' from environment 'basic-desktop-environment'

Traceback (most recent call last):
  File "/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 1041, in run
    return self.command.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/group.py", line 423, in run
    self.base.conf.strict)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 1643, in env_group_install
    cnt += self.environment_install(env_id, types, strict=strict)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 1571, in environment_install
    strict)
  File "/usr/lib/python3.6/site-packages/dnf/comps.py", line 93, in install_or_skip
    return install_fnc(grp_or_env_id, types, exclude, strict)
  File "/usr/lib/python3.6/site-packages/dnf/comps.py", line 564, in _environment_install
    for comps_group in comps_env.optional_groups:
  File "/usr/lib/python3.6/site-packages/dnf/comps.py", line 262, in optional_groups
    return [self._build_group(gi) for gi in self.option_ids]
  File "/usr/lib/python3.6/site-packages/dnf/comps.py", line 262, in <listcomp>
    return [self._build_group(gi) for gi in self.option_ids]
  File "/usr/lib/python3.6/site-packages/dnf/comps.py", line 249, in _build_group
    raise ValueError(msg % (grp_id.name, self.id))
ValueError: no group 'hawaii-desktop' from environment 'basic-desktop-environment'

Local variables in innermost frame:
msg: "no group '%s' from environment '%s'"
grp: None
grp_id: <libcomps.GroupId object at 0x7faaf3e275b8>
self: <dnf.comps.Environment object at 0x7faaf3dfa9b0>

Comment 1 Paul DeStefano 2018-07-07 22:41:34 UTC
Created attachment 1457241 [details]
File: _var_log_dnf.log

Comment 2 Paul DeStefano 2018-07-07 22:41:35 UTC
Created attachment 1457242 [details]
File: backtrace

Comment 3 Paul DeStefano 2018-07-07 22:41:36 UTC
Created attachment 1457243 [details]
File: cgroup

Comment 4 Paul DeStefano 2018-07-07 22:41:37 UTC
Created attachment 1457244 [details]
File: cpuinfo

Comment 5 Paul DeStefano 2018-07-07 22:41:38 UTC
Created attachment 1457245 [details]
File: dnf-makecache.log

Comment 6 Paul DeStefano 2018-07-07 22:41:39 UTC
Created attachment 1457246 [details]
File: environ

Comment 7 Paul DeStefano 2018-07-07 22:41:40 UTC
Created attachment 1457247 [details]
File: mountinfo

Comment 8 Paul DeStefano 2018-07-07 22:41:41 UTC
Created attachment 1457248 [details]
File: namespaces

Comment 9 Paul DeStefano 2018-07-07 22:41:42 UTC
Created attachment 1457249 [details]
File: open_fds

Comment 10 Dridi Boukelmoune 2018-07-13 07:42:05 UTC
This looks like a duplicate of bug 1594519, I have the same problem.

Comment 11 Jan Kurik 2018-08-14 09:55:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 12 Stéphane Wirtel 2018-08-27 10:49:10 UTC
I confirm the same bug with Fedora 28.

Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 1016, in run
    return self.command.run()
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/group.py", line 382, in run
    return self._info(extcmds)
  File "/usr/lib/python3.6/site-packages/dnf/cli/commands/group.py", line 115, in _info
    self.output.display_groups_in_environment(env)
  File "/usr/lib/python3.6/site-packages/dnf/cli/output.py", line 820, in display_groups_in_environment
    (_(' Optional Groups:'), names(environment.optional_groups)))
  File "/usr/lib/python3.6/site-packages/dnf/comps.py", line 245, in optional_groups
    return [self._build_group(gi) for gi in self.option_ids]
  File "/usr/lib/python3.6/site-packages/dnf/comps.py", line 245, in <listcomp>
    return [self._build_group(gi) for gi in self.option_ids]
  File "/usr/lib/python3.6/site-packages/dnf/comps.py", line 232, in _build_group
    raise ValueError(msg % (grp_id.name, self.id))
ValueError: no group 'hawaii-desktop' from environment 'basic-desktop-environment'

Comment 13 Jaroslav Mracek 2019-06-30 19:05:24 UTC
The problem is fixed by https://github.com/rpm-software-management/dnf/pull/1397 that is part of dnf-4.2.7

Comment 14 Fedora Update System 2019-08-14 07:23:56 UTC
FEDORA-2019-d4b6ede072 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4b6ede072

Comment 15 Fedora Update System 2019-08-16 20:12:18 UTC
dnf-4.2.5-4.fc29, dnf-plugins-extras-4.0.4-2.fc29, libdnf-0.31.0-6.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4b6ede072

Comment 16 Fedora Update System 2019-08-31 01:38:45 UTC
dnf-4.2.5-4.fc29, dnf-plugins-extras-4.0.4-2.fc29, libdnf-0.31.0-6.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.