Bug 1599036 - Wifi does not work on home connection with Intel Corporation Wireless 7260 with F28
Summary: Wifi does not work on home connection with Intel Corporation Wireless 7260 wi...
Keywords:
Status: CLOSED DUPLICATE of bug 1578486
Alias: None
Product: Fedora
Classification: Fedora
Component: wpa_supplicant
Version: 28
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Davide Caratti
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-08 05:51 UTC by Nigel Babu
Modified: 2020-01-13 19:33 UTC (History)
28 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-13 17:36:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Nigel Babu 2018-07-08 05:51:19 UTC
After the upgrade the F28, my laptop's wifi refuses to connect on my home connection.


$ dmesg | grep  '\(wifi\)\|\(wlp3s0\)'

[   21.640649] iwlwifi 0000:03:00.0: loaded firmware version 17.948900127.0 op_mode iwlmvm                                                                                                                [58/1669]
[   21.821620] iwlwifi 0000:03:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[   21.839989] iwlwifi 0000:03:00.0: base HW address: 4c:eb:42:ab:96:1d
[   22.060389] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[   24.238454] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   24.473839] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready                     
[   24.725932] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   24.813628] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   26.733897] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   28.505102] wlp3s0: authenticate with 68:14:01:06:72:72
[   28.507719] wlp3s0: send auth to 68:14:01:06:72:72 (try 1/3)
[   28.510637] wlp3s0: authenticated
[   28.511037] wlp3s0: associate with 68:14:01:06:72:72 (try 1/3)
[   28.514755] wlp3s0: RX AssocResp from 68:14:01:06:72:72 (capab=0x431 status=0 aid=1)
[   28.517692] wlp3s0: associated
[   28.533165] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[   84.751475] wlp3s0: deauthenticating from 68:14:01:06:72:72 by local choice (Reason: 3=DEAUTH_LEAVING)
[   84.759908] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   84.768329] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   88.537658] wlp3s0: authenticate with 88:cc:45:03:61:55
[   88.539810] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[   88.542369] wlp3s0: authenticated
[   88.542824] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[   88.546607] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=0 aid=1)
[   88.548166] wlp3s0: associated
[   88.579753] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[   88.580417] wlp3s0: deauthenticating from 88:cc:45:03:61:55 by local choice (Reason: 1=UNSPECIFIED)
[   88.604566] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[   90.436415] wlp3s0: authenticate with 88:cc:45:03:61:55
[   90.438575] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[   90.441887] wlp3s0: authenticated
[   90.442817] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[   90.446632] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=30 aid=1)
[   90.446635] wlp3s0: 88:cc:45:03:61:55 rejected association temporarily; comeback duration 672203520 TU (1141637 ms)
[   91.052640] iwlwifi 0000:03:00.0: No beacon heard and the time event is over already...
[   91.052677] wlp3s0: Connection to AP 88:cc:45:03:61:55 lost
[   95.442962] wlp3s0: aborting association with 88:cc:45:03:61:55 by local choice (Reason: 3=DEAUTH_LEAVING)
[   97.698404] wlp3s0: authenticate with 88:cc:45:03:61:55
[   97.700467] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[   97.702748] wlp3s0: authenticated
[   97.703810] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[   97.707576] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=0 aid=1)
[   97.709083] wlp3s0: associated
[   97.739498] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[   97.740214] wlp3s0: deauthenticating from 88:cc:45:03:61:55 by local choice (Reason: 1=UNSPECIFIED)
[   99.594759] wlp3s0: authenticate with 88:cc:45:03:61:55
[   99.596885] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[   99.599251] wlp3s0: authenticated
[   99.599823] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[   99.603668] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=30 aid=1)
[   99.603672] wlp3s0: 88:cc:45:03:61:55 rejected association temporarily; comeback duration 672203520 TU (1141637 ms)
[  100.211022] iwlwifi 0000:03:00.0: No beacon heard and the time event is over already...                                                                                                                 [7/1669]
[  100.211080] wlp3s0: Connection to AP 88:cc:45:03:61:55 lost
[  104.599321] wlp3s0: aborting association with 88:cc:45:03:61:55 by local choice (Reason: 3=DEAUTH_LEAVING)
[  106.853259] wlp3s0: authenticate with 88:cc:45:03:61:55
[  106.855644] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[  106.859141] wlp3s0: authenticated
[  106.859994] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[  106.863998] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=0 aid=1)
[  106.868093] wlp3s0: associated
[  106.900835] wlp3s0: deauthenticating from 88:cc:45:03:61:55 by local choice (Reason: 1=UNSPECIFIED)
[  108.755563] wlp3s0: authenticate with 88:cc:45:03:61:55
[  108.757979] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[  108.760474] wlp3s0: authenticated
[  108.761782] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[  108.765643] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=30 aid=1)
[  108.765652] wlp3s0: 88:cc:45:03:61:55 rejected association temporarily; comeback duration 672203520 TU (1141637 ms)
[  109.372288] iwlwifi 0000:03:00.0: No beacon heard and the time event is over already...
[  109.372375] wlp3s0: Connection to AP 88:cc:45:03:61:55 lost
[  113.765220] wlp3s0: aborting association with 88:cc:45:03:61:55 by local choice (Reason: 3=DEAUTH_LEAVING)
[  116.022909] wlp3s0: authenticate with 88:cc:45:03:61:55
[  116.025123] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[  116.030421] wlp3s0: authenticated
[  116.030948] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[  116.034728] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=0 aid=1)
[  116.036230] wlp3s0: associated
[  116.070513] wlp3s0: deauthenticating from 88:cc:45:03:61:55 by local choice (Reason: 1=UNSPECIFIED)
[  117.924073] wlp3s0: authenticate with 88:cc:45:03:61:55
[  117.926235] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[  117.928597] wlp3s0: authenticated
[  117.928936] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[  117.932765] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=30 aid=1)
[  117.932771] wlp3s0: 88:cc:45:03:61:55 rejected association temporarily; comeback duration 672203520 TU (1141637 ms)
[  118.540388] iwlwifi 0000:03:00.0: No beacon heard and the time event is over already...
[  118.540412] wlp3s0: Connection to AP 88:cc:45:03:61:55 lost
[  122.933867] wlp3s0: aborting association with 88:cc:45:03:61:55 by local choice (Reason: 3=DEAUTH_LEAVING)
[  125.186408] wlp3s0: authenticate with 88:cc:45:03:61:55
[  125.188416] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[  125.190768] wlp3s0: authenticated
[  125.192954] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[  125.198832] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=0 aid=1)
[  125.200507] wlp3s0: associated
[  125.241430] wlp3s0: deauthenticating from 88:cc:45:03:61:55 by local choice (Reason: 1=UNSPECIFIED)
[  127.096845] wlp3s0: authenticate with 88:cc:45:03:61:55
[  127.099311] wlp3s0: send auth to 88:cc:45:03:61:55 (try 1/3)
[  127.101787] wlp3s0: authenticated
[  127.102971] wlp3s0: associate with 88:cc:45:03:61:55 (try 1/3)
[  127.106802] wlp3s0: RX AssocResp from 88:cc:45:03:61:55 (capab=0x1411 status=30 aid=1)
[  127.106804] wlp3s0: 88:cc:45:03:61:55 rejected association temporarily; comeback duration 672203520 TU (1141637 ms)
[  127.713384] iwlwifi 0000:03:00.0: No beacon heard and the time event is over already...
[  127.713411] wlp3s0: Connection to AP 88:cc:45:03:61:55 lost
[  132.107234] wlp3s0: aborting association with 88:cc:45:03:61:55 by local choice (Reason: 3=DEAUTH_LEAVING)
[  133.558467] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[  133.561117] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[  135.296367] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[  137.071259] wlp3s0: authenticate with 68:14:01:06:72:72
[  137.073392] wlp3s0: send auth to 68:14:01:06:72:72 (try 1/3)
[  137.075741] wlp3s0: authenticated
[  137.075958] wlp3s0: associate with 68:14:01:06:72:72 (try 1/3)
[  137.079401] wlp3s0: RX AssocResp from 68:14:01:06:72:72 (capab=0x431 status=0 aid=1)
[  137.082584] wlp3s0: associated
[  137.092398] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready


Relevant output from lshw

        *-pci:1                                                                                                                                                                                                    
             description: PCI bridge                                                                                                                                                                               
             product: 8 Series/C220 Series Chipset Family PCI Express Root Port #2                                                                                                                                 
             vendor: Intel Corporation                                                                                                                                                                             
             physical id: 1c.1                                                                                                                                                                                     
             bus info: pci@0000:00:1c.1                                                                                                                                                                            
             version: d4                                                                                                                                                                                           
             width: 32 bits                                                                                                                                                                                        
             clock: 33MHz                                                                                                                                                                                          
             capabilities: pci normal_decode bus_master cap_list                                                                                                                                                   
             configuration: driver=pcieport                                                                                                                                                                        
             resources: irq:17 memory:f0400000-f04fffff                                                                                                                                                            
           *-network                                                                                                                                                                                               
                description: Wireless interface                                                                                                                                                                    
                product: Wireless 7260                                                                                                                                                                             
                vendor: Intel Corporation                                                                                                                                                                          
                physical id: 0                                                                                                                                                                                     
                bus info: pci@0000:03:00.0                                                                                                                                                                         
                logical name: wlp3s0                                                                                                                                                                               
                version: bb                                                                                                                                                                                        
                serial: 4c:eb:42:ab:96:1d                                                                                                                                                                          
                width: 64 bits                                                                                                                                                                                     
                clock: 33MHz                                                                                                                                                                                       
                capabilities: bus_master cap_list ethernet physical wireless                                                                                                                                       
                configuration: broadcast=yes driver=iwlwifi driverversion=4.17.3-200.fc28.x86_64 firmware=17.948900127.0 ip=192.168.223.100 latency=0 link=yes multicast=yes wireless=IEEE 802.11                  
                resources: irq:33 memory:f0400000-f0401fff



Current kernel version: Linux athena 4.17.3-200.fc28.x86_64 #1 SMP Tue Jun 26 14:17:07 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Comment 1 Nigel Babu 2018-07-08 05:52:34 UTC
Works perfectly fine on my hotspot's wifi. Currently working around this by using a wired connection. This also works fine on other networks. However, nothing on this network has changed post-upgrade.

Comment 3 Chris Tatman 2018-07-17 21:09:46 UTC
I have just noticed this exact, same behavior on my Thinkpad W541 with F28 and the 4.17.2-200 kernel. I also freshly installed F28 a couple weeks ago. Previously, I was using F25 with no issues connecting to any wifi networks.

I do know that the wifi was able to associate and connect to my work's guest network after the F28 install, but I cannot recall if my home network has been working since the update.

Usually I have the laptop docked with hard wired connection, but am on vacation this week and cannot connect to the wifi AP in my rental house. Weird thing is, all my other devices (android and windows 10) can connect to this AP. And when I enable the hotspot on my mobile, my laptop associates and authenticates to the mobile hotspot.

I can see verbatim the exact messages in my logs that Nigel has posted here. And the wireless device on my laptop is also the Intel 7260 (rev bb).

I was finally able to locate an ethernet cable and directly connect to the Access Point - a Technicolor TC8717T. The default encrytption was set to WPA2-PSK(AES), and when I changed it to 'open' and rebooted the device, I was eventually able to associate and obtain an IP via wifi.

However, when I tried to change the security back to any of the other WPA options, I was unable to connect.

I wonder if this could be a bug in the wpa_supplicant package?

--Chris

Comment 4 Phil 2018-07-24 15:06:53 UTC
I upgraded from Fedora 28 last night and I can no longer connect to my wifi access point. No othe rchanges have happened and my other devices can still connect. I have a Dell Inspiron 5565 (AMD A12 processor. results of lspci for the wireless card:
Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31

Comment 5 Phil 2018-07-24 15:10:42 UTC

Also from dmesg | grep  '\(wifi\)\|\(wlp2s0\)'



[39664.541619] wlp2s0: authenticate with 50:09:59:7f:52:ac
[39664.570840] wlp2s0: send auth to 50:09:59:7f:52:ac (try 1/3)
[39664.572022] wlp2s0: authenticated
[39664.572986] wlp2s0: associate with 50:09:59:7f:52:ac (try 1/3)
[39664.574331] wlp2s0: RX AssocResp from 50:09:59:7f:52:ac (capab=0x1011 status=0 aid=1)
[39664.578012] wlp2s0: associated
[39664.619234] wlp2s0: deauthenticating from 50:09:59:7f:52:ac by local choice (Reason: 1=UNSPECIFIED)
[39664.780907] wlp2s0: authenticate with 50:09:59:7f:52:ab
[39664.820921] wlp2s0: send auth to 50:09:59:7f:52:ab (try 1/3)
[39664.823120] wlp2s0: authenticated
[39664.823981] wlp2s0: associate with 50:09:59:7f:52:ab (try 1/3)
[39664.827918] wlp2s0: RX AssocResp from 50:09:59:7f:52:ab (capab=0x1411 status=30 aid=0)
[39664.827926] wlp2s0: 50:09:59:7f:52:ab rejected association temporarily; comeback duration 672203520 TU (1141637 ms)
[39669.827360] wlp2s0: aborting association with 50:09:59:7f:52:ab by local choice (Reason: 3=DEAUTH_LEAVING)
[39674.309770] wlp2s0: authenticate with 50:09:59:7f:52:ac
[39674.339357] wlp2s0: send auth to 50:09:59:7f:52:ac (try 1/3)
[39674.343343] wlp2s0: authenticated
[39674.344057] wlp2s0: associate with 50:09:59:7f:52:ac (try 1/3)
[39674.345254] wlp2s0: RX AssocResp from 50:09:59:7f:52:ac (capab=0x1011 status=30 aid=0)
[39674.345260] wlp2s0: 50:09:59:7f:52:ac rejected association temporarily; comeback duration 672203520 TU (1141637 ms)
[39679.348167] wlp2s0: aborting association with 50:09:59:7f:52:ac by local choice (Reason: 3=DEAUTH_LEAVING)


Phil

Comment 6 Phil 2018-07-25 19:56:43 UTC
I just verified that it is the version of wpa_supplicant in Fedora 28. I removed it and installed the Fedora 27 version 2.6-11.fc27. It now works.

Phil

Comment 7 Chris Tatman 2018-07-27 13:35:08 UTC
I wonder - Could this also have something to do with the way the model of wireless access point is configured and/or is implementing WPA/WPA2 security? 

I am back home now, and currently working on my home wifi Access Point. My home AP is a TP-LINK Archer C9 model, and security is set to WPA/WPA2-Personal and it is set up to automatically negotiate WPA-PSK or WPA2-PSK, TKIP, and AES dependent on how the client tries to connect.

Everything is working fine for me right now with F28 and the following package:
wpa_supplicant-2.6-16.fc28.x86_64

The AP in my rental was a model that is supplied by Spectrum/Time Warner (Technicolor TC8717T) and it most definitely did not allow my F28 laptop to associate unless I completely disabled security.

--Chris

Comment 8 Chris Tatman 2018-07-27 13:42:08 UTC
Output of iwconfig when connected to my home AP:

wlp3s0    IEEE 802.11  ESSID:"Midian_5G"  
          Mode:Managed  Frequency:5.22 GHz  Access Point: 60:E3:27:AD:74:A8   
          Bit Rate=300 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-38 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:28   Missed beacon:0

Comment 10 Davide Caratti 2018-08-01 10:45:18 UTC
(In reply to Chris Tatman from comment #7)
> I wonder - Could this also have something to do with the way the model of
> wireless access point is configured and/or is implementing WPA/WPA2
> security? 
> 
> I am back home now, and currently working on my home wifi Access Point. My
> home AP is a TP-LINK Archer C9 model, and security is set to
> WPA/WPA2-Personal and it is set up to automatically negotiate WPA-PSK or
> WPA2-PSK, TKIP, and AES dependent on how the client tries to connect.
> 
> Everything is working fine for me right now with F28 and the following
> package:
> wpa_supplicant-2.6-16.fc28.x86_64
> 
> The AP in my rental was a model that is supplied by Spectrum/Time Warner
> (Technicolor TC8717T) and it most definitely did not allow my F28 laptop to
> associate unless I completely disabled security.
> 
> --Chris

hello Chris and Phil,

sorry for the late answer.

Another user reported troubles when trying to connect to TC8717T using f28 (see: https://bugzilla.redhat.com/show_bug.cgi?id=1578486#c10 ). he managed to connect successfully by disabling PMF on the client, as follows:

$ nmcli connection modify  wifi-sec.pmf disable; nmcli connection up

can any of you try this?
thanks!
-- 
davide

Comment 11 Nigel Babu 2018-08-13 00:52:37 UTC
I can confirm that wifi-sec.pmf gets wifi to connect successfully

Comment 12 Davide Caratti 2018-08-13 17:36:59 UTC
thanks Nigel, marking as duplicate of bz1578486.

It would be great if we obtain a capture of EAPOL packets exchanged with the TC8717 when pmf is 'optional' on the client:

# tcpdump -i any -s0 ether proto 0x8888e

(the 'any' is needed as wpa_supplicant wlp4s0 changes state when you try connecting to the AP)

so that at least we understand what's written in the RSN element.
Thank you in advance!
regards,
-- 
davide

*** This bug has been marked as a duplicate of bug 1578486 ***


Note You need to log in before you can comment on or make changes to this bug.