Bug 1599219 - configure fails complaining absence of libxml2-devel
Summary: configure fails complaining absence of libxml2-devel
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-09 08:58 UTC by Sachidananda Urs
Modified: 2018-10-23 15:13 UTC (History)
2 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:13:48 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sachidananda Urs 2018-07-09 08:58:37 UTC
Description of problem:

If libxml2-devel is installed after generating the configure script (for any reason whatsoever), autogen.sh has to be run again. Else, the configure script fails saying libxml2-devel is not installed, 
----
configure: error: libxml2 devel libraries not found
----
which is quite confusing and  misleading. 

However this is not the caes for other packages. We should add it in
a FAQ if fixing this is not possible for any reason. 

Ref: https://lists.gluster.org/pipermail/gluster-users/2018-January/033302.html

Comment 1 Worker Ant 2018-07-30 15:19:51 UTC
REVIEW: https://review.gluster.org/20589 (build: use standard PKG_CHECK_MODULES for libxml2 availability) posted (#1) for review on master by Niels de Vos

Comment 2 Worker Ant 2018-08-16 06:55:53 UTC
COMMIT: https://review.gluster.org/20589 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- build: use standard PKG_CHECK_MODULES for libxml2 availability

In case the development parts of libxml2 are not installed, it was
required to re-run ./autogen.sh to cleanup the cached values for the
check. This is not nice towards users. By using the standard
PKG_CHECK_MODULES for libxml-2.0 the results of the check are not cached
and will be probed again when running ./configure.

Change-Id: I3c4586e5555a521be5d4fb61bdb873ae0317311a
Fixes: bz#1599219
Reported-by: Sachidananda Urs <surs@redhat.com>
Signed-off-by: Niels de Vos <ndevos@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:13:48 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.