Bug 1599235 - latex2man: Unescaped left brace in regex is illegal here in regex
Summary: latex2man: Unescaped left brace in regex is illegal here in regex
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive-base
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-09 09:29 UTC by Sebastian Kisela
Modified: 2018-08-07 01:14 UTC (History)
1 user (show)

Fixed In Version: texlive-base-20170520-41.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-07 01:14:17 UTC


Attachments (Terms of Use)
Build log where error is printed out. (140.39 KB, text/plain)
2018-07-09 09:29 UTC, Sebastian Kisela
no flags Details

Description Sebastian Kisela 2018-07-09 09:29:25 UTC
Created attachment 1457423 [details]
Build log where error is printed out.

Description of problem:

pstoedit on f28 fails to build due to potential bug in latex2man which is part of texlive-base.


Version-Release number of selected component (if applicable): 
texlive-latex2man-7:20170520-37.fc28.noarch


How reproducible:
Easily.

Steps to Reproduce:
1. fedpkg clone pstoedit
2. cd pstoedit && fedpkg switch-branch f28
3. fedpkg mockbuild

Actual results:
...
latex2man -t ./pstoedit.trans -M pstoedit.tex pstoedit.1
pdflatex pstoedit.tex
latex2man -t ./pstoedit.trans -H pstoedit.tex pstoedit.htm
Unescaped left brace in regex is illegal here in regex; marked by <-- HERE in m/\\([a-zA-Z]+){([^}]*)}{ <-- HERE ([^}]*)}/ at /usr/bin/latex2man line 1329.
make[1]: *** [Makefile:641: pstoedit.1] Error 255
make[1]: *** Waiting for unfinished jobs....
Unescaped left brace in regex is illegal here in regex; marked by <-- HERE in m/\\([a-zA-Z]+){([^}]*)}{ <-- HERE ([^}]*)}/ at /usr/bin/latex2man line 1329.
make[1]: *** [Makefile:644: pstoedit.htm] Error 255
This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017) (preloaded format=pdflatex)
 restricted \write18 enabled.
...



Expected results:
Successful build.


Additional info:
Seems to be discussed and resolved in debian:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=871159

Failed build with logs:
https://koji.fedoraproject.org/koji/taskinfo?taskID=28091438

Comment 1 Fedora Update System 2018-07-23 14:05:18 UTC
texlive-2016-51.20160520.fc28 texlive-base-20170520-41.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3a432edcc8

Comment 2 Fedora Update System 2018-07-23 14:05:32 UTC
texlive-2016-51.20160520.fc28 texlive-base-20170520-41.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3a432edcc8

Comment 3 Fedora Update System 2018-07-23 22:21:16 UTC
texlive-2016-51.20160520.fc28, texlive-base-20170520-41.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3a432edcc8

Comment 4 Fedora Update System 2018-08-07 01:14:17 UTC
texlive-2016-51.20160520.fc28, texlive-base-20170520-41.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.