Bug 1599516 - [autofs] The log no longer print PID of automount process
Summary: [autofs] The log no longer print PID of automount process
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: autofs
Version: 7.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: Kun Wang
URL:
Whiteboard:
Depends On:
Blocks: 1689469
TreeView+ depends on / blocked
 
Reported: 2018-07-10 01:53 UTC by Kun Wang
Modified: 2019-08-06 13:10 UTC (History)
4 users (show)

Fixed In Version: autofs-5.0.7-100.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1689469 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:10:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch - add NULL check in prepare_attempt_prefix() (999 bytes, patch)
2018-12-11 02:40 UTC, Ian Kent
no flags Details | Diff
Patch - update build info with systemd (927 bytes, patch)
2018-12-11 02:43 UTC, Ian Kent
no flags Details | Diff
Patch - use flags for startup boolean options (6.36 KB, patch)
2018-12-11 02:45 UTC, Ian Kent
no flags Details | Diff
Patch - move close stdio descriptors to become_daemon() (3.18 KB, patch)
2018-12-11 02:46 UTC, Ian Kent
no flags Details | Diff
Patch - add systemd service command line option (4.48 KB, patch)
2018-12-11 02:47 UTC, Ian Kent
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2250 None None None 2019-08-06 13:10:39 UTC

Description Kun Wang 2018-07-10 01:53:09 UTC
Description of problem:

When testing autofs-5.0.7-92.el7, I found the PID of automount which is very useful for tracking issues no longer exists in the log.

Version-Release number of selected component (if applicable):
autofs-5.0.7-92.el7,

How reproducible:
always

Steps to Reproduce:
1.enable debug log in /etc/autofs.conf
2.start autofs service
3.check log

Actual results:
pid missing (ex:automount: mount_mount: mount(nfs): calling mount -t nfs4......)

Expected results:
print pid (ex:automount[11909]: mount_mount: mount(nfs): calling mount -t nfs4...)

Additional info:

Comment 4 Ian Kent 2018-12-11 02:40:55 UTC
Created attachment 1513230 [details]
Patch - add NULL check in prepare_attempt_prefix()

Not strictly related but I noticed the problem while working on this so I felt compelled to include it.

Comment 5 Ian Kent 2018-12-11 02:43:16 UTC
Created attachment 1513231 [details]
Patch - update build info with systemd

Not strictly related but it is a change to the systemd support code which is being updated in this bug.

Comment 6 Ian Kent 2018-12-11 02:45:25 UTC
Created attachment 1513232 [details]
Patch - use flags for startup boolean options

Comment 7 Ian Kent 2018-12-11 02:46:26 UTC
Created attachment 1513233 [details]
Patch - move close stdio descriptors to become_daemon()

Comment 8 Ian Kent 2018-12-11 02:47:24 UTC
Created attachment 1513234 [details]
Patch - add systemd service command line option

Comment 10 Kun Wang 2019-04-12 05:17:36 UTC
Verified based on below test result:

##########################################
# on unfixed version autofs-5.0.7-99.el7 #
##########################################

[01:13:12 root@ ~~]# cat /var/log/messages | grep "automount\[[0-9]\+\]"
:: [ 01:13:12 ] :: [   FAIL   ] :: Running 'cat /var/log/messages | grep "automount\[[0-9]\+\]" ' (Expected 0, got 1)

############################################################
# on fixed version autofs-5.0.7-100.el7 and later releases #
############################################################

Apr 12 01:16:24 hp-dl180g6-01 automount[3425]: dev_ioctl_send_ready: token = 3
Apr 12 01:16:24 hp-dl180g6-01 automount[3425]: mounted /root/lc1599516/lctest
:: [ 01:16:24 ] :: [   PASS   ] :: Running 'cat /var/log/messages | grep "automount\[[0-9]\+\]" ' (Expected 0, got 0)

Comment 12 errata-xmlrpc 2019-08-06 13:10:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2250


Note You need to log in before you can comment on or make changes to this bug.