Bug 1599549 - Recent Vulkan update conflicts with wine packages in updates Fedora 28
Summary: Recent Vulkan update conflicts with wine packages in updates Fedora 28
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-10 04:13 UTC by vblanton@gmail.com
Modified: 2018-07-19 17:47 UTC (History)
3 users (show)

Fixed In Version: wine-3.12-1.fc28 wine-3.12-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-11 05:36:40 UTC
Type: Bug


Attachments (Terms of Use)

Description vblanton@gmail.com 2018-07-10 04:13:23 UTC
Description of problem:
Recent release of Vulkan updates conflicts with wine packages. Asks to remove Wine.

Version-Release number of selected component (if applicable):
vulkan-loader            i686        1.1.77.0-4.fc28        updates      111 k

How reproducible:
every time on my system

Steps to Reproduce:
1. run "sudo dnf update" with latest mesa and wine installed"
2. complains about "packages with conflicts" 
3. run "sudo dnf update --best --allowerasing"
4. vulkan-loader, replacing a number of vulkan packages, wants to remove wine and various associated wine packages. see below details. 

Actual results:

"sudo dnf --best --allowerasing" output:

Installing dependencies:
 vulkan-loader         x86_64       1.1.77.0-4.fc28        updates        105 k
     replacing  vulkan.i686 1.1.73.0-1.fc28
     replacing  vulkan.x86_64 1.1.73.0-1.fc28
     replacing  vulkan-filesystem.noarch 1.1.73.0-1.fc28
Removing dependent packages:
 wine                  x86_64       3.11-1.fc28            @updates         0  
 wine-alsa             i686         3.11-1.fc28            @updates       196 k
 wine-capi             i686         3.11-1.fc28            @updates        85 k
 wine-cms              i686         3.11-1.fc28            @updates       130 k
 wine-core             i686         3.11-1.fc28            @updates       193 M
 wine-ldap             i686         3.11-1.fc28            @updates       366 k
 wine-openal           i686         3.11-1.fc28            @updates       115 k
 wine-opencl           i686         3.11-1.fc28            @updates       111 k
 wine-pulseaudio       i686         3.11-1.fc28            @updates       175 k
 wine-twain            i686         3.11-1.fc28            @updates       228 k



Expected results:
vulkan to not conflict with wine?


Additional info:
Thanks :D Please let me know if any other information is useful.

Comment 1 Michael Cronenworth 2018-07-10 13:20:17 UTC
I'm not sure what is wrong with your system, but I do not have any package conflicts here.

Comment 2 Fedora Update System 2018-07-10 17:56:01 UTC
wine-3.12-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d7dc73e363

Comment 3 Fedora Update System 2018-07-10 17:57:25 UTC
wine-3.12-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba193458f8

Comment 4 vblanton@gmail.com 2018-07-11 05:36:40 UTC
I don't think there is anything wrong with my system, but I do think it might be conflicting weirdly with an old copr with latest mesa and llvm I had. allowing it to erase wine, and then reinstalling, showed this:

Installing:
 wine                     x86_64      3.11-1.fc28            updates       58 k
Installing dependencies:
 mesa-vulkan-drivers      i686        18.0.5-2.fc28          updates      1.9 M
 vulkan-loader            i686        1.1.77.0-4.fc28        updates      111 k
 wine-alsa                i686        3.11-1.fc28            updates      110 k
 wine-capi                i686        3.11-1.fc28            updates       64 k
 wine-cms                 i686        3.11-1.fc28            updates       79 k
 wine-core                i686        3.11-1.fc28            updates       26 M
 wine-ldap                i686        3.11-1.fc28            updates      131 k
 wine-openal              i686        3.11-1.fc28            updates       71 k
 wine-opencl              i686        3.11-1.fc28            updates       70 k
 wine-pulseaudio          i686        3.11-1.fc28            updates      101 k
 wine-twain               i686        3.11-1.fc28            updates       91 k
Downgrading:
 clang-libs               x86_64      6.0.0-5.fc28           fedora        15 M
 llvm-libs                i686        6.0.0-11.fc28          fedora        17 M
 llvm-libs                x86_64      6.0.0-11.fc28          fedora        15 M
 mesa-dri-drivers         i686        18.0.5-2.fc28          updates       14 M
 mesa-dri-drivers         x86_64      18.0.5-2.fc28          updates       12 M
 mesa-filesystem          i686        18.0.5-2.fc28          updates       30 k
 mesa-filesystem          x86_64      18.0.5-2.fc28          updates       30 k
 mesa-libGL               i686        18.0.5-2.fc28          updates      197 k
 mesa-libGL               x86_64      18.0.5-2.fc28          updates      177 k
 mesa-libGL-devel         x86_64      18.0.5-2.fc28          updates      173 k
 mesa-libGLES             x86_64      18.0.5-2.fc28          updates       28 k
 mesa-libGLES-devel       x86_64      18.0.5-2.fc28          updates       71 k
 mesa-libOSMesa           i686        18.0.5-2.fc28          updates      2.3 M
 mesa-libOSMesa           x86_64      18.0.5-2.fc28          updates      2.2 M
 mesa-libOpenCL           x86_64      18.0.5-2.fc28          updates      350 k
 mesa-libgbm              i686        18.0.5-2.fc28          updates       53 k
 mesa-libgbm              x86_64      18.0.5-2.fc28          updates       51 k
 mesa-libgbm-devel        x86_64      18.0.5-2.fc28          updates       33 k
 mesa-libglapi            i686        18.0.5-2.fc28          updates       69 k
 mesa-libglapi            x86_64      18.0.5-2.fc28          updates       58 k
 mesa-libxatracker        x86_64      18.0.5-2.fc28          updates      1.2 M
 mesa-vulkan-drivers      x86_64      18.0.5-2.fc28          updates      1.6 M

Hence, since it isn't an issue with the fedora package, I think it is safe to close this bug. 

It was helpful to know that the issue wasn't widespread to recall what else it might be.

Comment 5 Fedora Update System 2018-07-11 19:17:39 UTC
wine-3.12-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba193458f8

Comment 6 Fedora Update System 2018-07-11 23:42:51 UTC
wine-3.12-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d7dc73e363

Comment 7 Fedora Update System 2018-07-18 18:30:36 UTC
wine-3.12-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-07-19 17:47:38 UTC
wine-3.12-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.