Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1599815 - (CVE-2018-10891) CVE-2018-10891 moodle: Quiz question bank import preview could execute JavaScript
CVE-2018-10891 moodle: Quiz question bank import preview could execute JavaSc...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Product Security
impact=low,public=20180709,reported=2...
: Security
Depends On: 1599816 1599817
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-10 11:56 EDT by Laura Pardo
Modified: 2018-07-10 11:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: moodle 3.5.1, moodle 3.4.4, moodle 3.3.7, moodle 3.1.13
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laura Pardo 2018-07-10 11:56:13 EDT
A flaw was found in Moodle. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.


References:
http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-62820
Comment 1 Laura Pardo 2018-07-10 11:56:38 EDT
Created moodle tracking bugs for this issue:

Affects: epel-7 [bug 1599817]
Affects: fedora-all [bug 1599816]

Note You need to log in before you can comment on or make changes to this bug.