Bug 160 - IDE Hard-Drive Detection Inconsistencies with RH5.2
IDE Hard-Drive Detection Inconsistencies with RH5.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
5.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-22 21:20 EST by gadown
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-01-11 22:45:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gadown 1998-11-22 21:20:00 EST
Using the boot disks supplied with RH5.2 I noticed the
following problem.

I'm trying to install RH5.2-Intel on a standard PC with IDE
drives and an atapi CD-ROM.  I'm installing RH on the
secondary-master drive.  It is a WD34000.  I have 2 other
WD34000 drives (primary-master and primary-slave - for
other OS).  HDC has no partitions on it.  When the boot
disk boots I notice the following output:
"
hda: WDC AC34000L, 3815MB w/256kB Cache, CHS=969/128/63,DMA
hdb: WDC AC34000L, 3815MB w/256kB Cache, CHS=969/128/63,DMA
hdc: WDC AC34000L, 3815MB w/256kB Cache, CHS=7752/16/63,DMA
...
partition check:
  hda: [969/128/63] hda1
  hdb: [969/128/63] hdb1
  hdc:
"
For some reason RH dectects HDC using normal mode not
LBA.(yes the bios was set to dected all drives as lba -
Win95 shows drives properly).  When I use disk druid it
complains that they are more than 1024 cyls and will not
partition HDC properly.


Second, I boot up with dos and create an extended partion
on HDC with 2 drives (2GIG each).  Now when I boot up with
the boot disk I see the following output:
"
hda: WDC AC34000L, 3815MB w/256kB Cache, CHS=969/128/63,DMA
hdb: WDC AC34000L, 3815MB w/256kB Cache, CHS=969/128/63,DMA
hdc: WDC AC34000L, 3815MB w/256kB Cache, CHS=7752/16/63,DMA
...
partition check:
  hda: [969/128/63] hda1
  hdb: [969/128/63] hdb1
  hdc: [PTBL] [969/128/63] hdc1<hdc5, hdc6>
"
Now because HDC has partitions on it, RH seems to have no
problem with it.  I can use RH-fdisk to change the logical
drives to type 83's.  I can then install RH with no
problems.

Problem 1 - Secondary channels are not recognized by kernel
properly.
Problem 2 - Secondary channels are recongnized properly if
they have a partition created outside of Linux (ie dos)

Also what is the PTBL in the HDC line and why does it not
appear in the line for HDA or HDB.  And why does it only
appear when a partition exists.
Comment 1 David Lawrence 1998-11-23 12:18:59 EST
From my understanding these lines

hda: WDC AC34000L, 3815MB w/256kB Cache, CHS=969/128/63,DMA
hdb: WDC AC34000L, 3815MB w/256kB Cache, CHS=969/128/63,DMA
hdc: WDC AC34000L, 3815MB w/256kB Cache, CHS=7752/16/63,DMA
...
partition check:
  hda: [969/128/63] hda1
  hdb: [969/128/63] hdb1
  hdc: [PTBL] [969/128/63] hdc1<hdc5, hdc6>

are basically saying is that the hard drive geometry that is stored in
the partition table is disagreeing with waht the BIOS itself is
reporting. Before we continue I would double check that the BIOS is
set at LBA on all three drives and not just the first two. I would
choose NONE in all of the ide devices under standard CMOS setup. Then
go to the IDE AUTODETECTION part and make sure LBA is manually
selected for each of the drives. The try the install again to see if
you get the same information.
Comment 2 gadown 1998-11-24 00:40:59 EST
I did as you described.  Instead of using auto dectection I forced
the bios to use LBA.  The same problem again.  Any drives on the
secondary channel are detected by the kernel in normal mode not LBA.
Win98/NT have no problem (that's whats on HDA and HDB - so I know
it's not the motherboard bios - ASUS P2L97 with lastest bios).  I
also tried using RH 5.1 it also has the same problem.

The boot sequence displays the follows:
"
hda: WDC AC34000L, 3815MB w/256kB Cache, CHS=969/128/63,DMA
hdb: WDC AC34000L, 3815MB w/256kB Cache, CHS=969/128/63,DMA
hdc: WDC AC34000L, 3815MB w/256kB Cache, CHS=7752/16/63,DMA
...
partition check:
  hda: hda1
  hdb: hdb1
  hdc:    <--> if no partitions defined OR
  hdc: [PTBL] [969/128/63] hdc1<hdc5, hdc6> <--> defined extended in
dos
"

Again, if there are no partitions on HDC then druid/fdisk will report
that there are > 1024 cyls.  If there are partitions created by
another OS (like dos) then druid/fdisk will work with the drive and
partitions with no problem.
Comment 3 David Lawrence 1998-11-24 16:51:59 EST
Did this drive originally have any disk management software loaded on
it such as EzDrive or OnTrack disk management? If so then you could
use a low level utility to clean out the first sectors of the drive
which will wipe out any partition information that may be lingering
around and then create the new partitions with linux fdisk during the
install. Also if we could know what BIOS your motherboard has on it
such as Award Bios (most common) or AMI bios. This could also be
helpful.
Comment 4 gadown 1998-11-28 16:10:59 EST
There is no disk management software loaded on the drives.  The bios
is already capable of doing LBA transalations.
I'm using an ASUS P2L97 motherboard with an award bios.  The bios is
at the most current level support by ASUS.
Comment 5 Edward Schlunder 1998-12-04 20:06:59 EST
If you put the hdc drive on the primary IDE port instead, does it get
detected properly? That is, is this problem specific to the drive or
the fact that it is set up to be hdc rather than hdb/hda?
Comment 6 gadown 1998-12-04 20:21:59 EST
First, I have 3 identical drives.  I have tried swapping them around.
Any drive that is on the secondary channel is detected in normal node
instead of LBA.  It is not a problem with the motherboard because
dos/Win95/Win98/WintNT will work with the drive correctly.  Also when
the bios detects the drives they are all detected in LBA mode.  It
appears that the kernel has a problem with the secondary channel.
Comment 7 Jay Turner 1998-12-09 10:58:59 EST
One thing that I noticed is that you did not mention where you were
putting the /boot Linux partition.  You are going to need to locate
that on 1 of the 2 drives that are on your primary channel.  This will
allow you to boot your Linux installtion.  As for the drive
recoginition during installtion, the kernal is in effect ignoring the
stats of the drives on the secondary channel, as those drives cannot
be used to boot the system.  The fact that LBA mode is or is not being
recognized by Linux is not really a concern, as the only thing the
lack of LBA mode is going to cause problems during is accessing those
drives from other operating sytems, not from within Linux.
Comment 8 gadown 1998-12-09 11:42:59 EST
> Last comments:
> One thing that I noticed is that you did not mention where you were
> putting the /boot Linux partition.  You are going to need to locate
> that on 1 of the 2 drives that are on your primary channel.This will
> allow you to boot your Linux installtion.  As for the drive
> recoginition during installtion, the kernal is in effect ignoring
> the stats of the drives on the secondary channel, as those drives
> cannot be used to boot the system.

No that is incorrect.  I'm using PowerQuest's boot manager which
allows linux to boot from the secondary channel.  Lilo is installed
on hdc(hdc5).

> The fact that LBA mode is or is not being recognized by Linux is
> not really a concern, as the only thing the lack of LBA mode is
> going to cause problems during is accessing those
> drives from other operating sytems, not from within Linux.

Yes it is a concern.  If the drive on the secondary channel has no
partitions already defined then when I use disk druid/fdisk on linux
they report that there are more than 1024 cyls and attempts to
partition the drive are incorrect because it is partitioned without
LBA translation.  But if the drive has partitions on it already then
the druid/fdisk can add or delete partition correctly.
Question: Have you guys tried putting an IDE drive on the secondary
channel as describe in the original opening of the problem.  I'm not
sure why we are discussing booting linux when the problem is simply
drives on the secondary channel do not get recognized by Linux
correctly.  Win95/98/NT have no problem with the secondary channel.
Comment 9 David Lawrence 1998-12-09 13:57:59 EST
We have been able to verify the problem in the testlab with the
following configuration.

1.2 GB IDE primary
4.0 GB IDE secondary

the bios info for the secondary controller isnt readily available
for the kernel to access according to a developer.

if you need to set geometries set them when you fdisk the drive
(expert mode) - the kernel trusts the partition table above all else.
Or you can just use hdc=ccc,hh,ss on the command line and this will
also work. Then you can add it to your lilo.conf file to make it
permanent.
Comment 10 Matt Wilson 1999-01-11 22:45:59 EST
LBA addressing isn't easy to get for drives other than primary.  Under
Linux you don't really need it anyway.

Note You need to log in before you can comment on or make changes to this bug.