Bug 16000 - tripwire crashes when a direcory used as a config file
Summary: tripwire crashes when a direcory used as a config file
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: tripwire (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-11 15:56 UTC by mal
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-14 16:48:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mal 2000-08-11 15:56:50 UTC
When command line option which corresponds to a file 
is set to a directory - tripwire crashes.

tripwire -c /tmp/     
Segmentation fault (core dumped)

tripwire -d /tmp/
Segmentation fault (core dumped)

non-existent files are OK, it does not crash, it just prints
error message.

tripwire -c /tmp/ggggg
couldn't open /tmp/ggggg: No such file or directory

Comment 1 Ngo Than 2000-08-14 16:15:54 UTC
i can't reproduce this problem.

tripwire -d /tmp/
Unknown mode specified: -d
Use --help to get help.

i don't see Segmentation fault (core dumped)

Comment 2 mal 2000-08-14 16:48:29 UTC
tripwite from PowerTools Beta
Clean install of RedHat 7.0 beta and tripwiate form powertools afterward

tripwire -version

Tripwire version 1.2 (patchlevel 2)

Copyright (c) 1992, 1993, 1994 Purdue Research Foundation
	By Gene Kim, Eugene Spafford

[root@clienthost /root]# rpm -q tripwire  
tripwire-1.2-10

 tripwire -c /tmp/
Segmentation fault (core dumped)

tripwire --help
usage: tripwire [ options ... ]
	Where `options' are:
		-initialize	Database Generation mode
		-init		
		-update entry	update entry (a file, directory, or 
				    tw.config entry) in the database
		-interactive	Integrity Checking mode with
				    Interactive entry updating
		-loosedir	use looser checking rules for directories
		-d dbasefile	read in database from dbasefile
				    (use `-d -' to read from stdin)
		-c configfile	read in config file from configfile
				    (use `-c -' to read from stdin)
		-cfd fd	    read in config file from specified fd
		-dfd fd	    read in the database file from specified fd
		-Dvar=value	define a tw.config variable (ala @@define)
		-Uvar		undefine a tw.config variable (ala @@undef)
		-i #|all 	ignore the specified signature (to reduce
				    execution time)
		-q		quiet mode
		-v		verbose mode
		-preprocess	print out preprocessed configuration file
		-E		
		-help		print out interpretation help message
		-version	print version and patch information

You may use different version of tripwire.
ls -l /usr/sbin/tripwire 
-rwx------    1 root     root       434664 Jul 24 22:45 /usr/sbin/tripwire



Comment 3 Ngo Than 2000-08-14 17:27:40 UTC
tripwire-1.2-10 is obsoletes was removed from powertools.
We have the new tripwire-2.3 in RC1. It does't have this problem




Note You need to log in before you can comment on or make changes to this bug.