Bug 1600063 - Deploying logging on a system where /tmp mounted with noexec option fails [NEEDINFO]
Summary: Deploying logging on a system where /tmp mounted with noexec option fails
Keywords:
Status: CLOSED DUPLICATE of bug 1600685
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.7.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-11 10:52 UTC by Feras Al Taher
Modified: 2018-07-12 20:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-12 20:32:50 UTC
Target Upstream Version:
jcantril: needinfo? (tkatarki)


Attachments (Terms of Use)

Description Feras Al Taher 2018-07-11 10:52:26 UTC
Description of problem:

Deploying logging on a system where /tmp mounted with noexec option fails

In the file below there is task executes a script o /tmp directory,
this is hardcoded to be executed on /tmp directory.

openshift/openshift-ansible/roles/openshift_logging_fluentd/tasks/label_and_wait.yaml

- name: Execute the fluentd temporary labeling script
  command: "/tmp/fluentd_label.temp.sh {{ fluentd_host }}"
  with_items: "{{ openshift_logging_fluentd_hosts }}"
  loop_control:
    loop_var: fluentd_host

When a system mounts the /tmp directory with noexec option this task fails with the error below,

2018-06-01 15:34:15,427 p=626 u=karel |  failed: [i********************] (item=hrrlyicplv005.msnet.railb.be) => {
    "changed": false,
    "cmd": "/tmp/fluentd_label.temp.sh h****************",
    "fluentd_host": "h***********",
    "invocation": {
        "module_args": {
            "_raw_params": "/tmp/fluentd_label.temp.sh h****************",
            "_uses_shell": false,
            "chdir": null,
            "creates": null,
            "executable": null,
            "removes": null,
            "stdin": null,
            "warn": true
        }
    },
    "msg": "[Errno 13] Permission denied",
    "rc": 13
}


Version-Release number of the following components:
Ansible: ansible 2.5.3
Git: openshift-ansible-3.9.29-1

How reproducible:
Allways

Steps to Reproduce:
1. Mount the /tmp directory with noexec option
2. Install the looging component

Actual results:
ansible log will be added to the case.


Upstream issue:
https://github.com/openshift/openshift-ansible/issues/8517

Comment 4 Feras Al Taher 2018-07-12 20:32:50 UTC

*** This bug has been marked as a duplicate of bug 1600685 ***


Note You need to log in before you can comment on or make changes to this bug.