Bug 1600319 - singularity-2.6.0-rc2 is available
Summary: singularity-2.6.0-rc2 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: singularity
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Bockelman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-12 00:35 UTC by Upstream Release Monitoring
Modified: 2018-08-23 11:26 UTC (History)
3 users (show)

Fixed In Version: singularity-2.6.0-1.1.fc27 singularity-2.6.0-1.1.fc28 singularity-2.6.0-1.1.el6 singularity-2.6.0-1.1.el7
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-08 20:23:36 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2018-07-12 00:35:03 UTC
Latest upstream release: 2.6.0-rc1
Current version/release in rawhide: 2.5.2-1.fc29
URL: http://singularityware.github.io/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/10920/

Comment 1 Brian Bockelman 2018-07-13 17:51:07 UTC
dwd - can you take a crack at this?  Obviously it's not the final release, but it would be a good exercise in the Fedora tooling (now that we fixed your committer access).  It would also allow us to have everything prepped for 2.6.0 in case we need to rush things again.

Comment 2 Dave Dykstra 2018-07-14 06:24:34 UTC
The EPEL packaging mechanism does not get along with the upstream's practice of having the github tag (2.6.0-rc1) not match the internal version number (2.5.99), and I don't see how to get around that unless I ask them to also make the latter tag.

Also, I won't have much opportunity to work on it until Wednesday due to travels.

Comment 3 Brian Bockelman 2018-07-14 09:12:55 UTC
Seems that the tagging issue could be solved with a few lines of macros and / or a simple patch, right?  Testing RCs seems to be a good way to start the release verification process before the actual release -- this would allow us to speed up the release process, especially for security releases.

No problem if you're traveling through Wednesday.  Just thought it would be a good exercise.

Comment 4 Dave Dykstra 2018-07-16 18:40:11 UTC
Ok, Brian, I figured out how to do it by using the release download tarball instead of the github archive interface.  I had to change the .spec %build step to ignore any existing configure script and always run autogen.sh.  I made a PR for rawhide so far, https://src.fedoraproject.org/rpms/singularity/pull-request/12.

Comment 5 Dave Dykstra 2018-07-17 13:10:25 UTC
I did fedpkg build on that PR, and replicated the changes on the 4 other branches.  I intended to turn them into pull requests too but hadn't done --set-upstream on the branches so accidentally pushed the rpms/singularity repository this time.  I started fedpkg build on el6, epel6, f27, and f28.

Comment 6 Upstream Release Monitoring 2018-07-24 12:35:20 UTC
Latest upstream release: 2.6.0-rc2
Current version/release in rawhide: 2.5.99-1.1.fc29
URL: http://singularityware.github.io/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/10920/

Comment 7 Fedora Update System 2018-07-24 22:26:28 UTC
singularity-2.5.999-1.4.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-36fcc12db0

Comment 8 Fedora Update System 2018-07-24 22:29:55 UTC
singularity-2.5.999-1.4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-65cccc0ef8

Comment 9 Fedora Update System 2018-07-24 22:30:40 UTC
singularity-2.5.999-1.4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5e7d7166b4

Comment 10 Fedora Update System 2018-07-24 22:31:21 UTC
singularity-2.5.999-1.4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9078145d4a

Comment 11 Fedora Update System 2018-07-25 19:36:52 UTC
singularity-2.5.999-1.4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5e7d7166b4

Comment 12 Fedora Update System 2018-07-25 19:51:57 UTC
singularity-2.5.999-1.4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-65cccc0ef8

Comment 13 Fedora Update System 2018-07-25 20:05:18 UTC
singularity-2.5.999-1.4.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-36fcc12db0

Comment 14 Fedora Update System 2018-07-26 11:49:29 UTC
singularity-2.5.999-1.4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-65cccc0ef8

Comment 15 Fedora Update System 2018-07-26 12:01:29 UTC
singularity-2.5.999-1.4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9078145d4a

Comment 16 Fedora Update System 2018-08-07 18:39:54 UTC
singularity-2.6.0-1.1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cdbb680f44

Comment 17 Fedora Update System 2018-08-07 18:59:32 UTC
singularity-2.6.0-1.1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-27b0c7c109

Comment 18 Fedora Update System 2018-08-07 19:01:19 UTC
singularity-2.6.0-1.1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-c189fbeea1

Comment 19 Fedora Update System 2018-08-07 19:02:35 UTC
singularity-2.6.0-1.1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-eb6476d410

Comment 20 Fedora Update System 2018-08-08 14:26:45 UTC
singularity-2.6.0-1.1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-27b0c7c109

Comment 21 Fedora Update System 2018-08-08 17:14:35 UTC
singularity-2.6.0-1.1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cdbb680f44

Comment 22 Fedora Update System 2018-08-08 17:34:38 UTC
singularity-2.6.0-1.1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-c189fbeea1

Comment 23 Fedora Update System 2018-08-08 17:36:04 UTC
singularity-2.6.0-1.1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-eb6476d410

Comment 24 Dave Dykstra 2018-08-08 20:23:36 UTC

*** This bug has been marked as a duplicate of bug 1612442 ***

Comment 25 Fedora Update System 2018-08-16 07:23:33 UTC
singularity-2.6.0-1.1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2018-08-16 08:05:36 UTC
singularity-2.6.0-1.1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2018-08-23 10:53:29 UTC
singularity-2.6.0-1.1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2018-08-23 11:26:04 UTC
singularity-2.6.0-1.1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.