Bug 1600675 - CJK Default Fonts To Noto
Summary: CJK Default Fonts To Noto
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Cotton
QA Contact:
URL:
Whiteboard:
: 1534559 1534560 1541950 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-12 18:29 UTC by Ben Cotton
Modified: 2019-05-03 08:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-03 08:13:08 UTC
Type: ---


Attachments (Terms of Use)

Description Ben Cotton 2018-07-12 18:29:10 UTC
This is a tracking bug for Change: CJK Default Fonts To Noto
For more details, see: https://fedoraproject.org//wiki/Changes/CJKDefaultFontsToNoto

Changes the default fonts for Chinese, Japanese, and Korean (CJK) languages to Google Noto.

Comment 1 Akira TAGOH 2018-07-23 09:55:53 UTC
all of the fontconfig priority for relevant (CJK) fonts packages has been updated. that looks like:

/etc/fonts/conf.d/65-0-google-noto-sans-cjk-ttc.conf
/etc/fonts/conf.d/65-0-google-noto-serif-cjk-ttc.conf
...
/etc/fonts/conf.d/65-2-adobe-source-han-sans-cn.conf
/etc/fonts/conf.d/65-2-adobe-source-han-sans-tw.conf
/etc/fonts/conf.d/65-2-adobe-source-han-serif-cn.conf
/etc/fonts/conf.d/65-2-adobe-source-han-serif-tw.conf
/etc/fonts/conf.d/65-2-naver-nanum-barun-gothic.conf
/etc/fonts/conf.d/65-2-naver-nanum-barun-pen.conf
/etc/fonts/conf.d/65-2-naver-nanum-brush.conf
/etc/fonts/conf.d/65-2-naver-nanum-gothic.conf
/etc/fonts/conf.d/65-2-naver-nanum-myeongjo.conf
/etc/fonts/conf.d/65-2-naver-nanum-pen.conf
/etc/fonts/conf.d/65-2-vlgothic-pgothic.conf
/etc/fonts/conf.d/65-3-naver-nanum-gothic-coding.conf
/etc/fonts/conf.d/65-3-vlgothic-gothic.conf
...

Even if google-noto-*-cjk-ttc-fonts won't get installed where is likely to be seen on upgrading, old default fonts is still be the priority so they can still use similarly to older releases.

Anyway, we are ready to test.

Comment 2 Jan Kurik 2018-08-14 11:22:19 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 3 Akira TAGOH 2018-11-01 07:40:27 UTC
*** Bug 1534559 has been marked as a duplicate of this bug. ***

Comment 4 Akira TAGOH 2018-11-01 07:40:30 UTC
*** Bug 1534560 has been marked as a duplicate of this bug. ***

Comment 5 Akira TAGOH 2018-11-01 07:43:36 UTC
*** Bug 1541950 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.