Bug 1600918 - [Disperse] : Client side heal is not removing dirty flag for some of the files.
Summary: [Disperse] : Client side heal is not removing dirty flag for some of the files.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: disperse
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: RHGS 3.5.0
Assignee: Pranith Kumar K
QA Contact: Upasana
URL:
Whiteboard:
Depends On: 1593224 1693223 1739446 1805050
Blocks: 1696807
TreeView+ depends on / blocked
 
Reported: 2018-07-13 11:37 UTC by Upasana
Modified: 2020-02-20 07:35 UTC (History)
10 users (show)

Fixed In Version: glusterfs-6.0-7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1593224
Environment:
Last Closed: 2019-10-30 12:19:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
bug recreate script (1022 bytes, application/x-shellscript)
2019-07-01 10:04 UTC, Ashish Pandey
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1655617 0 high CLOSED [GSS][Assistance required to clean up pending healing entries in a distribute disperse volume ] 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2019:3249 0 None None None 2019-10-30 12:20:03 UTC

Internal Links: 1655617

Description Upasana 2018-07-13 11:37:54 UTC
+++ This bug was initially created as a clone of Bug #1593224 +++

Description of problem:

While server side heal is disabled, client side heal is not removing dirty flag for some files.

Version-Release number of selected component (if applicable):


How reproducible:
50%

Steps to Reproduce:
1. Create a 4+2 volume and mount 
2. Touch 100 files
3. Kill one brick
4. write some data all files using dd
5.  bricng the bricks UP
6. Append some data on all the bricks using dd, this will trigger heal on all the files
7. Read data from all the files using dd command.

At the end all files should be healed. However, I have observed that 2-3 files are still showing up in heal info.
When I looked for the getxattr, all the xattrs were same and dirty flag was still present for data fop.





 




  
Actual results:


Expected results:


Additional info:

Comment 3 Vivek Das 2018-08-12 15:13:51 UTC
As the bug doesn't meet the blocker criteria. Moving this out of 3.4.0.

Comment 22 Pranith Kumar K 2019-06-24 09:43:08 UTC
https://code.engineering.redhat.com/gerrit/174385

Comment 28 Ashish Pandey 2019-07-01 10:04:52 UTC
Created attachment 1586213 [details]
bug recreate script

Comment 39 errata-xmlrpc 2019-10-30 12:19:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3249


Note You need to log in before you can comment on or make changes to this bug.