Bug 1600997 - selinux blocks {map} from automount_t to fsadm_exec_t
Summary: selinux blocks {map} from automount_t to fsadm_exec_t
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-13 14:33 UTC by Patrik Kis
Modified: 2018-10-30 10:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:07:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:08:12 UTC

Description Patrik Kis 2018-07-13 14:33:26 UTC
Description of problem:

The following AVC denial was logged while accessing a file mounted with autofs. The operation was not blocked.

type=PROCTITLE msg=audit(1531429252.680:1347): proctitle="(null)"
type=PATH msg=audit(1531429252.680:1347): item=1 name="/lib64/ld64.so.1" inode=69263323 dev=fd:00 mode=0100755 ouid=0 ogid=0 rdev=00:00 obj=system_u:object_r:ld_so_t:s0 objtype=NORMAL cap_fp=0000000000000000 cap_fi=0000000000000000 cap_fe=0 cap_fver=0
type=PATH msg=audit(1531429252.680:1347): item=0 name="/usr/sbin/fsck.ext4" inode=69230489 dev=fd:00 mode=0100755 ouid=0 ogid=0 rdev=00:00 obj=system_u:object_r:fsadm_exec_t:s0 objtype=NORMAL cap_fp=0000000000000000 cap_fi=0000000000000000 cap_fe=0 cap_fver=0
type=CWD msg=audit(1531429252.680:1347):  cwd="/"
type=SYSCALL msg=audit(1531429252.680:1347): arch=80000015 syscall=11 success=no exit=-13 a0=3fff86703628 a1=3fff879367d0 a2=1000b0318e0 a3=8 items=2 ppid=16168 pid=16199 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="fsck.ext4" exe="/usr/sbin/fsck.ext4" subj=system_u:system_r:automount_t:s0 key=(null)
type=AVC msg=audit(1531429252.680:1347): avc:  denied  { map } for  pid=16199 comm="fsck.ext4" path="/usr/sbin/fsck.ext4" dev="dm-0" ino=69230489 scontext=system_u:system_r:automount_t:s0 tcontext=system_u:object_r:fsadm_exec_t:s0 tclass=file permissive=0

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-207.el7

How reproducible:
always

Steps to Reproduce:
1. Configure autofs
2. Try to access a file

Comment 2 Lukas Vrabec 2018-07-20 10:26:46 UTC

*** This bug has been marked as a duplicate of bug 1460322 ***

Comment 5 errata-xmlrpc 2018-10-30 10:07:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.