Bug 1601004 - selinux blocks {map} from kadmind_t to krb5kdc_principal_t
Summary: selinux blocks {map} from kadmind_t to krb5kdc_principal_t
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-13 14:42 UTC by Patrik Kis
Modified: 2018-10-30 10:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:07:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:08:12 UTC

Description Patrik Kis 2018-07-13 14:42:10 UTC
Description of problem:

The following AVC denial was logged when executed our krb5 propagation test.

type=PROCTITLE msg=audit(07/13/2018 09:01:04.088:452) : proctitle=/usr/sbin/kadmind -P /var/run/kadmind.pid -r SAFETY-INSPECTOR.SECTOR7G.NUCLEAR-POWER-PLANT.SPRINGSFIELD.NET 
type=SYSCALL msg=audit(07/13/2018 09:01:04.088:452) : arch=ppc64 syscall=mmap success=yes exit=(null)(Unknown error 1999110144) a0=0x0 a1=0x10000000 a2=PROT_READ|PROT_WRITE a3=MAP_SHARED items=0 ppid=1 pid=22741 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=kadmind exe=/usr/sbin/kadmind subj=system_u:system_r:kadmind_t:s0 key=(null) 
type=AVC msg=audit(07/13/2018 09:01:04.088:452) : avc:  denied  { map } for  pid=22741 comm=kadmind path=/var/kerberos/krb5kdc/principal.ulog dev="dm-0" ino=34969058 scontext=system_u:system_r:kadmind_t:s0 tcontext=system_u:object_r:krb5kdc_principal_t:s0 tclass=file permissive=1 

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-207.el7

How reproducible:
always

Steps to Reproduce:
Not sure if the AVC denial were logged while kadmind was started or when it executed and action.
Will try to narrow it down.

Comment 5 errata-xmlrpc 2018-10-30 10:07:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.