Bug 1601041 - [RFE] RBD namespaces
Summary: [RFE] RBD namespaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 3.2
Hardware: All
OS: Unspecified
high
medium
Target Milestone: rc
: 4.0
Assignee: Jason Dillaman
QA Contact: Gopi
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1730176
TreeView+ depends on / blocked
 
Reported: 2018-07-13 16:38 UTC by Sheldon Mustard
Modified: 2020-01-31 12:45 UTC (History)
7 users (show)

Fixed In Version: ceph-14.2.0
Doc Type: Enhancement
Doc Text:
.Segregating RBD images within isolated namespaces within the same pool RBD images can now be segregated within isolated namespaces within the same pool. When using Ceph Block Devices directly without a higher-level system, such as OpenStack or OpenShift Container Storage, it was not possible to restrict user access to specific RBD images. When combined with CephX capabilities, users can be restricted to specific pool namespaces to restrict access to RBD images.
Clone Of:
Environment:
Last Closed: 2020-01-31 12:44:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:45:28 UTC

Description Sheldon Mustard 2018-07-13 16:38:32 UTC
Description of problem:

Need the ability to have multiple namespaces within a pool and have that available to RBD images.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Giridhar Ramaraju 2019-08-05 13:06:22 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 6 Giridhar Ramaraju 2019-08-05 13:09:02 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 7 Yaniv Kaul 2019-08-27 07:00:31 UTC
Can we get a QA ack please?

Comment 13 Gopi 2020-01-13 05:48:57 UTC
Working the feature as expected on latest. 

ceph -v
ceph version 14.2.4-91.el8cp (23607558df3b077b6190cdf96cd8d9043aa2a1c5) nautilus (stable)
ceph-mon-14.2.4-91.el8cp.x86_64
ceph-ansible-4.0.6-1.el8cp.noarch

Comment 15 errata-xmlrpc 2020-01-31 12:44:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.