Bug 1601263 - New default fedora hardening flags break gnuradio < 3.7.13.4
Summary: New default fedora hardening flags break gnuradio < 3.7.13.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnuradio
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-15 18:37 UTC by Marcus Müller
Modified: 2018-07-31 18:02 UTC (History)
3 users (show)

Fixed In Version: gnuradio-3.7.13.4-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1610513 (view as bug list)
Environment:
Last Closed: 2018-07-31 18:02:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Marcus Müller 2018-07-15 18:37:28 UTC
Description of problem:

Due to Fedora 28 defaulting to `-D_GLIBCXX_ASSERTIONS`, a few (rather benigm) cases of undefined behaviour in GNU Radio's C++ code led to `aborts` (mainly, those were "getting the pointer to the second, optional, input stream, and then only using it if the block's actually configured to have two input streams"; they have since been fixed. (see CHANGELOG.md)

This happened in upstream release 3.7.13.4. Following upstream is hence strongly recommended!

Version-Release number of selected component (if applicable):

3.7.11-5 (F28/F27) to 3.7.13.3 (F28 updates/rawhide)

How reproducible:

reliably

Steps to Reproduce:

1. Generate flow graph with float_to_vector, but only one input. 
2. Run


Actual results:

Abort

Expected results:

Normal operation

Additional info:

Comment 1 Fedora Update System 2018-07-19 09:49:17 UTC
gqrx-2.11.5-4.fc28 gr-osmosdr-0.1.4-10.20170221git2a2236cc.fc28 gr-rds-1.1.0-3.fc28 gr-fcdproplus-3.7.2-0.4.rc1.20180618gite5ff8396.fc28 gr-iqbal-0.37.2-31.fc28 gr-air-modes-0-0.62.20160831git3bad1f5d.fc28 gnuradio-3.7.13.4-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-91f7ca30b1

Comment 2 Fedora Update System 2018-07-19 20:21:31 UTC
gnuradio-3.7.13.4-1.fc28, gqrx-2.11.5-4.fc28, gr-air-modes-0-0.62.20160831git3bad1f5d.fc28, gr-fcdproplus-3.7.2-0.4.rc1.20180618gite5ff8396.fc28, gr-iqbal-0.37.2-31.fc28, gr-osmosdr-0.1.4-10.20170221git2a2236cc.fc28, gr-rds-1.1.0-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-91f7ca30b1

Comment 3 Fedora Update System 2018-07-31 18:02:13 UTC
gnuradio-3.7.13.4-1.fc28, gqrx-2.11.5-4.fc28, gr-air-modes-0-0.62.20160831git3bad1f5d.fc28, gr-fcdproplus-3.7.2-0.4.rc1.20180618gite5ff8396.fc28, gr-iqbal-0.37.2-31.fc28, gr-osmosdr-0.1.4-10.20170221git2a2236cc.fc28, gr-rds-1.1.0-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.