Bug 160134 - fix network manager for my home network
fix network manager for my home network
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-10 22:57 EDT by Bill Nottingham
Modified: 2014-03-16 22:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-09 22:46:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make it work (617 bytes, patch)
2005-06-10 22:57 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2005-06-10 22:57:24 EDT
Patch attached.

Need to call set_wireless_config, otherwise the device isn't actually set as
ad-hoc, nor is the key or rate set to match the other node.

And, of course, I use DHCP on my ad-hoc network. :) Perhaps it should check
for dhcp, and then do autoip if that fails.
Comment 1 Bill Nottingham 2005-06-10 22:57:24 EDT
Created attachment 115322 [details]
patch to make it work
Comment 2 Dan Williams 2006-07-09 22:46:17 EDT
Somewhat obsolete since we use wpa_supplicant now.  However, there are a few
issues still with Ad-Hoc, mainly that wpa_supplicant doesn't support setting the
channel yet so "Create new Network..." doesn't work quite correctly.

Note You need to log in before you can comment on or make changes to this bug.