Bug 1601576 - [RFE] Allow all overcloud networks to be Neutron routed networks
Summary: [RFE] Allow all overcloud networks to be Neutron routed networks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 15.0 (Stein)
Assignee: Harald Jensås
QA Contact: Gurenko Alex
URL:
Whiteboard:
: 1503838 1598879 (view as bug list)
Depends On: 1740283
Blocks: 1747481
TreeView+ depends on / blocked
 
Reported: 2018-07-16 18:10 UTC by Ian Pilcher
Modified: 2019-09-26 10:45 UTC (History)
14 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190701110422.889d4d4.el8ost
Doc Type: Technology Preview
Doc Text:
Red Hat OpenStack Platform undercloud networks are now layer 3 (L3) capable. This enhancement enables all segments to use one network, and alleviates the need for service net map overrides. This enhancement is important for Red Hat OpenStack Platform edge computing sites that deploy roles in different sites and make service net map overrides unwieldy.
Clone Of:
Environment:
Last Closed: 2019-09-21 11:16:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 582180 0 'None' MERGED L3 routed networks - data + env (1/3) 2021-01-26 14:09:20 UTC
OpenStack gerrit 582181 0 'None' MERGED L3 routed networks - network.j2 (2/3) 2021-01-26 14:10:03 UTC
OpenStack gerrit 582301 0 'None' MERGED L3 routed networks - subnet fixed_ips (3/3) 2021-01-26 14:09:20 UTC
OpenStack gerrit 595570 0 'None' MERGED Allow networks in roles_data to be dict or list 2021-01-26 14:09:20 UTC
OpenStack gerrit 604943 0 'None' MERGED Add ctlplane interface routes 2021-01-26 14:10:02 UTC
OpenStack gerrit 608471 0 'None' ABANDONED Replace tripleo_common/utils/roles.py validate_role_yaml() 2021-01-26 14:09:20 UTC
OpenStack gerrit 613442 0 'None' MERGED Add a tag's containing subnet cidr to ctlplane network 2021-01-26 14:09:21 UTC
OpenStack gerrit 613459 0 'None' MERGED Make NetCidrMapValue contain list of cidrs in each net 2021-01-26 14:09:21 UTC
OpenStack gerrit 613487 0 'None' MERGED Extend DeployedServerPortMap to include network props 2021-01-26 14:09:21 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:18:42 UTC

Internal Links: 1337770

Description Ian Pilcher 2018-07-16 18:10:08 UTC
This is a bit of a follow-on to https://bugzilla.redhat.com/show_bug.cgi?id=1599910

The more I think about this, the more I think that hieradata overrides are
a (painful) workaround for the fact that we're abusing composable networks
for an inappropriate use case.  This may be somewhat doable for compute
nodes, but it would seem to be almost completely impractical for any other
role, and there are legitimate reasons for putting other roles on "leaf"
networks:

1) We'd like to put a Glance API server in remote sites to act as a shared
   image cache for the compute nodes at that site.

2) Customers are very interested in having hyper-converged compute/Ceph
   nodes at remote sites.

3) For the non-remote spine & leaf case, it wouldn't be at all unreasonable
   for a customer to distribute control plane functions other than VIPs/
   HAProxy across their racks.

And I'm sure that there are others.

My gut tells me that the "right" way to do this would be to enable Neutron
routed networks for all of the overcloud networks (as we do for the control
plane network today).

Comment 1 Ian Pilcher 2018-07-17 14:34:55 UTC
I just stumbled across this -

https://blueprints.launchpad.net/tripleo/+spec/tripleo-routed-networks-templates

Comment 2 Ramon Acedo 2018-07-17 16:31:50 UTC
As per Harald's feedback:

https://review.openstack.org/582180
https://review.openstack.org/582181
https://review.openstack.org/582301

Distribution VIPs support pending though.

Comment 9 Bob Fournier 2018-12-17 19:12:10 UTC
*** Bug 1598879 has been marked as a duplicate of this bug. ***

Comment 10 Bob Fournier 2019-01-04 21:23:42 UTC
Moving this to POST as all patches have merged.  Any additional issues that come up should have bugs created.

Comment 15 John Fulton 2019-07-24 15:20:39 UTC
*** Bug 1503838 has been marked as a duplicate of this bug. ***

Comment 18 errata-xmlrpc 2019-09-21 11:16:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.