Bug 1601585 - grub2 uses linux16 instead of initrd16 since 2.02-38 (looks like typo while updating patch)
Summary: grub2 uses linux16 instead of initrd16 since 2.02-38 (looks like typo while u...
Keywords:
Status: CLOSED DUPLICATE of bug 1601578
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-16 18:57 UTC by Filipe Brandenburger
Modified: 2018-07-17 16:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-17 16:36:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1601578 None None None Never

Internal Links: 1601578

Description Filipe Brandenburger 2018-07-16 18:57:33 UTC
Description of problem:
grub2 generates invalid config on x86_64 without no EFI. In particular, it usehttps://src.fedoraproject.org/rpms/grub2/pull-request/6s "linux16" for the initramfs instead of "initrd16".

Version-Release number of selected component (if applicable):
grub2-tools-2.02-42.fc29.x86_64

How reproducible:
Every time.

Steps to Reproduce:
(On a machine with no EFI:)
1. sudo grub2-mkconfig -o /boot/grub2/grub.cfg
2. sudo grep initramfs /boot/grub2/grub.cfg

Actual results:
- Booting breaks with "error: invalid magic number."

Expected results:
- Booting works.
- Expected to see "initrd16" but seeing "linux16" instead.

Additional info:
Proposed fix here:
https://src.fedoraproject.org/rpms/grub2/pull-request/6

Comment 1 Adam Williamson 2018-07-17 16:36:32 UTC

*** This bug has been marked as a duplicate of bug 1601578 ***


Note You need to log in before you can comment on or make changes to this bug.