Bug 1601591 - aarch64 system fails to boot 'error: can't find command `linux'.'
Summary: aarch64 system fails to boot 'error: can't find command `linux'.'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: rawhide
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1601549 (view as bug list)
Depends On:
Blocks: ARMTracker IoT 1602041
TreeView+ depends on / blocked
 
Reported: 2018-07-16 19:23 UTC by Paul Whalen
Modified: 2018-08-13 10:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1602041 (view as bug list)
Environment:
Last Closed: 2018-08-13 10:09:52 UTC


Attachments (Terms of Use)

Description Paul Whalen 2018-07-16 19:23:24 UTC
Description of problem:
After updating to grub2-2.02-42.fc29 system fails to boot. 

Version-Release number of selected component (if applicable):
grub2-2.02-42.fc29

How reproducible:
everytime

Actual results:

error: can't find command `linux'.
error: can't find command `initrd'.

Press any key to continue...

Comment 1 Paul Whalen 2018-07-16 19:47:42 UTC
During the upgrade there are a number of tracebacks

Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/dnf/yum/rpmtrans.py", line 258, in callback
    self._uninst_progress(amount, total, key)
  File "/usr/lib/python3.7/site-packages/dnf/yum/rpmtrans.py", line 340, in _uninst_progress
    _, _, tsi = self._extract_cbkey(key)
  File "/usr/lib/python3.7/site-packages/dnf/yum/rpmtrans.py", line 230, in _extract_cbkey
    raise RuntimeError("TransactionItem not found for key: %s" % cbkey)
RuntimeError: TransactionItem not found for key: grub2-tools-minimal


Ending with:

The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 123, in cli_run
    ret = resolving(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 154, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 234, in do_transaction
    super(BaseCli, self).do_transaction(display)
  File "/usr/lib/python3.7/site-packages/dnf/base.py", line 904, in do_transaction
    self._run_transaction(cb=cb)
  File "/usr/lib/python3.7/site-packages/dnf/base.py", line 1048, in _run_transaction
    self._verify_transaction(cb.verify_tsi_package)
  File "/usr/lib/python3.7/site-packages/dnf/base.py", line 1084, in _verify_transaction
    self.history.end(rpmdbv, 0)
  File "/usr/lib/python3.7/site-packages/dnf/db/history.py", line 490, in end
    bool(return_code)
  File "/usr/lib64/python3.7/site-packages/libdnf/transaction.py", line 742, in endTransaction
    return _transaction.Swdb_endTransaction(self, dtEnd, rpmdbVersionEnd, state)
RuntimeError: C++ std::exception: TransactionItem state is not set: grub2-tools-1:2.02-37.fc29.aarch64

Comment 2 Paul Whalen 2018-07-16 20:11:16 UTC
Tracebacks are reproducible on x86_64, but the x86_64 system is bootable after the upgrade.

Comment 3 Mark Salter 2018-07-17 15:22:39 UTC
*** Bug 1601549 has been marked as a duplicate of this bug. ***

Comment 4 Paul Whalen 2018-07-17 15:32:55 UTC
no improvement with grub2-2.02-44.fc29

error: can't find command `linux'.
error: can't find command `initrd'.

Press any key to continue...

  Failed to boot both default and fallback entries.

Press any key to continue...

Also unable to reboot:

grub> reboot
error: can't find command `reboot'.

Comment 5 Paul Whalen 2018-07-18 15:31:58 UTC
Fixed in grub2-2.02-46.fc29, thanks Peter!

Comment 6 Adam Williamson 2018-07-24 20:15:30 UTC
Note, -46 wasn't in composes up to 20180723.n.0 for some reason, so tests continue to fail with those composes. It seems to have been tagged into 20180724.n.0 (which failed) and should also be in 20180724.n.1 (which is running now).


Note You need to log in before you can comment on or make changes to this bug.