Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 160160 - [patch] HTTP requests for CDDB queries are invalid
Summary: [patch] HTTP requests for CDDB queries are invalid
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: k3b
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-12 11:15 UTC by Enrico Scholz
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-06 03:51:42 UTC
Type: ---


Attachments (Terms of Use)
Adds ' HTTP/1.0' to the HTTP request (756 bytes, patch)
2005-06-12 11:15 UTC, Enrico Scholz
no flags Details | Diff

Description Enrico Scholz 2005-06-12 11:15:40 UTC
Description of problem:

The HTTP request generated for CDDB queries are invalid because they are missing
the trailing ' HTTP/1.0'. Attached patch fixes it.



Version-Release number of selected component (if applicable):

k3b-0.11.23-3


How reproducible:

100%


Steps to Reproduce:
1. configure a proxy manually (using KDE settings does not work)
2. try to make a CDDB query

  
Actual results:

query hangs and returns with a communication error after some time


Addition information:

Reported upstream at 
http://sourceforge.net/tracker/index.php?func=detail&aid=1219110&group_id=26138&atid=386332

Comment 1 Enrico Scholz 2005-06-12 11:15:41 UTC
Created attachment 115330 [details]
Adds ' HTTP/1.0' to the HTTP request

Comment 2 John Mahowald 2005-10-06 03:51:42 UTC
Obsoleted by KDE IO in 0.12 as per the upstream bug.


Note You need to log in before you can comment on or make changes to this bug.