Bug 1601695 - guest can not receive data from host via virtserialport via Unix socket backend
Summary: guest can not receive data from host via virtserialport via Unix socket backend
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: qemu-kvm
Version: 8.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 8.1
Assignee: Vadim Rozenfeld
QA Contact: liunana
URL:
Whiteboard:
Depends On: 1166031
Blocks: 1649160 1714393
TreeView+ depends on / blocked
 
Reported: 2018-07-17 04:31 UTC by lijin
Modified: 2020-06-23 20:14 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1166031
: 1714393 (view as bug list)
Environment:
Last Closed: 2020-05-13 01:17:23 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
serial testing scripts (295.67 KB, application/zip)
2018-09-11 02:02 UTC, lijin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 None None None 2018-07-17 04:31:26 UTC

Comment 3 lijin 2018-07-17 04:33:21 UTC
Can not reproduce with rhel7.5 version(qemu-kvm-rhev-2.10.0-21.el7.x86_64.rpm)

So it's a regression bug.

Comment 4 lijin 2018-07-17 04:43:00 UTC
steps are same with comment#0;

packages info:
qemu-kvm-rhev-2.12.0-7.el7.x86_64
kernel-3.10.0-919.el7.x86_64
virtio-win-prewhql-154
seabios-bin-1.11.0-2.el7.noarch

Comment 8 lijin 2018-09-11 02:02:02 UTC
Created attachment 1482249 [details]
serial testing scripts

Comment 14 Yu Wang 2019-05-28 02:49:58 UTC
Still reproduce it on rhel8.0.1 host

Version:
    virtio-win-1.9.8-0.el8
    qemu-kvm-3.1.0-26.module+el8.0.1+3232+83506298.x86_64
    kernel-4.18.0-80.1.2.el8_0.x86_64
    seabios-1.12.0-1.module+el8.0.1+2959+fecd1a40.x86_64

Thanks
Yu Wang

Comment 16 xiagao 2019-07-26 05:34:06 UTC
Can't reproduce this bug on RHEL8.1 host 

Version:   
qemu-kvm-4.0.0-6.module+el8.1.0+3736+a2aefea3.x86_64
kernel-4.18.0-112.el8.x86_64
seabios-1.12.0-3.module+el8.1.0+3627+66216cf4.x86_64
virtio-win-prewhql-0.1-172.iso
guest:win2019(1903)

Verify this bug.

Comment 17 Ademar Reis 2020-02-05 22:48:32 UTC
QEMU has been recently split into sub-components and as a one-time operation to avoid breakage of tools, we are setting the QEMU sub-component of this BZ to "General". Please review and change the sub-component if necessary the next time you review this BZ. Thanks

Comment 18 xiagao 2020-02-28 09:42:40 UTC
Hit this issue again, so reopen it.

kernel-4.18.0-179.el8.x86_64 intel
qemu-kvm-2.12.0-99.module+el8.2.0+5827+8c39933c.x86_64

But could not reproduce in qemu-kvm-tests-4.2.0-12.module+el8.2.0+5858+afd073bc.x86_64


Note You need to log in before you can comment on or make changes to this bug.