Bug 1601975 - libreswan has started to produce avc: denied { execute_no_trans }
Summary: libreswan has started to produce avc: denied { execute_no_trans }
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-17 14:51 UTC by Jaroslav Aster
Modified: 2018-10-30 10:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:07:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:08:12 UTC

Description Jaroslav Aster 2018-07-17 14:51:33 UTC
Description of problem:

libreswan has started to produce avc:  denied  { execute_no_trans }

time->Tue Jul 10 14:33:45 2018
type=PROCTITLE msg=audit(1531247625.465:6269): proctitle=2F7573722F6C6962657865632F69707365632F706C75746F002D2D6C65616B2D646574656374697665002D2D636F6E666967002F6574632F69707365632E636F6E66002D2D6E6F666F726B
type=PATH msg=audit(1531247625.465:6269): item=0 name="/usr/libexec/ipsec/addconn" inode=498818 dev=fd:00 mode=0100755 ouid=0 ogid=0 rdev=00:00 obj=system_u:object_r:ipsec_exec_t:s0 nametype=NORMAL cap_fp=0000000000000000 cap_fi=0000000000000000 cap_fe=0 cap_fver=0
type=CWD msg=audit(1531247625.465:6269): cwd="/run/pluto"
type=BPRM_FCAPS msg=audit(1531247625.465:6269): fver=0 fp=0000000000000000 fi=0000000000000000 fe=0 old_pp=00000000200074c4 old_pi=0000000000000000 old_pe=00000000200074c4 old_pa=0000000000000000 pp=0000000000003004 pi=0000000000000000 pe=0000000000003004 pa=0000000000000000
type=SYSCALL msg=audit(1531247625.465:6269): arch=c0000015 syscall=11 success=no exit=-13 a0=7fffc1d20bc8 a1=7fffc1d20ba0 a2=7fffc1d20b98 a3=0 items=1 ppid=26415 pid=26437 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="pluto" exe="/usr/libexec/ipsec/pluto" subj=system_u:system_r:ipsec_t:s0 key=(null)
type=AVC msg=audit(1531247625.465:6269): avc:  denied  { execute_no_trans } for  pid=26437 comm="pluto" path="/usr/libexec/ipsec/addconn" dev="dm-0" ino=498818 scontext=system_u:system_r:ipsec_t:s0 tcontext=system_u:object_r:ipsec_exec_t:s0 tclass=file permissive=0


Version-Release number of selected component (if applicable):

selinux-policy-3.13.1-207.el7.noarch


How reproducible:

100%


Steps to Reproduce:
1. Run test /CoreOS/libreswan/Sanity/Singlehost-systemd-sanity-test.


Actual results:

libreswan produces avc.


Expected results:

libreswan does not produce avc.

Comment 1 Milos Malik 2018-07-18 06:59:11 UTC
I believe this bug is a duplicate of BZ#1600684.

Comment 2 Lukas Vrabec 2018-07-18 08:00:52 UTC

*** This bug has been marked as a duplicate of bug 1600684 ***

Comment 5 errata-xmlrpc 2018-10-30 10:07:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.