Bug 1602282 - tests/bugs/bug-1371806_acl.t fails for distributed regression framework
Summary: tests/bugs/bug-1371806_acl.t fails for distributed regression framework
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-18 06:55 UTC by Deepshikha khandelwal
Modified: 2019-07-10 09:23 UTC (History)
3 users (show)

Fixed In Version: glusterfs-6.x
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-10 09:23:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
Tar of generated logs for this failed test(includes cli logs also) (16.26 KB, application/x-gzip)
2018-07-18 06:55 UTC, Deepshikha khandelwal
no flags Details
Tar of generated logs for this failed test(includes cli logs also) (1.81 MB, application/x-tar)
2018-07-18 18:57 UTC, Deepshikha khandelwal
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 20596 0 None Abandoned Use 'ls' instead of 'stat' in unit test bug-1371806_acl.t 2019-02-06 08:59:45 UTC

Description Deepshikha khandelwal 2018-07-18 06:55:32 UTC
Created attachment 1459659 [details]
Tar of generated logs for this failed test(includes cli logs also)

Description of problem:

tests/bugs/bug-1371806_acl.t is constantly failing for distributed regression framework. Tar of generated logs is attached for this test.

Comment 1 Mohit Agrawal 2018-07-18 12:55:58 UTC
This is expected behavior, the fix (custom user xattr heal) does not exist in 3.12 so test case will not work for 3.12.

Regards
Mohit Agrawal

Comment 2 Mohit Agrawal 2018-07-18 12:57:28 UTC
For more please refer below Gerrit link
https://review.gluster.org/#/c/19157/

Regards
Mohit Agrawal

Comment 3 Nigel Babu 2018-07-18 13:10:31 UTC
This is actually seen on master.

Comment 4 Deepshikha khandelwal 2018-07-18 18:57:31 UTC
Created attachment 1459794 [details]
Tar of generated logs for this failed test(includes cli logs also)

Comment 5 Mohit Agrawal 2018-07-19 03:34:54 UTC
Hi,

  As per test(.t) logs it is showing getfacl command output is not expected for 
  one directory on down brick.
  On the basis of currently available logs, it is difficult to say why it did not 
  happen for one directory only ?? I also tried to execute multiple times on 
  centos environment not able to reproduce it even tried of standard regression 
  (https://review.gluster.org/#/c/20529/) have not seen any failure.

  I think to debug it more either we need to enable debug log for bricks or need to put more debug logs in dht code.
  
  I think it is not consistently reproducible because I have not seen a failure 
  of this test case on regression build in recently merged patches.
  
  Can you please try in the same test case after enable debug logs for brick and 
  share the logs ??

 
Regards
Mohit Agrawal

Comment 6 Deepshikha khandelwal 2018-07-31 06:47:55 UTC
This test is now passing in the distributed regression framework.

RCA: The XFS partition /d which is supposed to be created in the distributed servers was not actually happening and using the existing device partitions.

Fix for this is: https://github.com/gluster/glusterfs-patch-acceptance-tests/pull/159/files
Earlier the state of mount module was 'present' which only specifies that the device is to be configured in fstab and does not trigger or create or require a mount.
Changed the state to 'mounted' in which the device will be actively mounted and appropriately configured in fstab. If the mount point is not present, the mount point will be created.

Comment 7 Worker Ant 2018-08-01 13:52:04 UTC
REVIEW: https://review.gluster.org/20596 (Use 'ls' instead of 'stat' in unit test bug-1371806_acl.t) posted (#2) for review on master by Deepshikha Khandelwal

Comment 8 Amar Tumballi 2019-07-10 09:23:51 UTC
Not seen in a long time.


Note You need to log in before you can comment on or make changes to this bug.