Bug 160252 - Radeon 7000 clock problems
Radeon 7000 clock problems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-13 16:37 EDT by Dimi Paun
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 19:59:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X configuration file *without* DRI (2.92 KB, text/plain)
2005-06-24 12:11 EDT, Dimi Paun
no flags Details
X logs *without* DRI (34.63 KB, text/plain)
2005-06-24 12:11 EDT, Dimi Paun
no flags Details

  None (edit)
Description Dimi Paun 2005-06-13 16:37:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
After updating the system (via yum) to the latest xorg RPM (6.8.2),
my ATI Radeon 7000 graphics card started misbehaving. Namely, my display
is a Dell 1905FP LCD screen connected to the graphics card via the digital
interface. The monitor would flip the image on/off every 1-2 seconds, as if
it doesn't understand the signal. Strangely enough, the analog interface works.

Now, I've checked the ChangeLog for the RPM, and there seems to be a couple of
patches that may have something to do with this behaviour:
    xorg-x11-6.8.1-ati-radeon-panel-timing-param-init-130888.patch
    xorg-x11-6.8.1-ati-radeon-mobility-display-detection-fix2.patch
    xorg-x11-6.8.1-ati-radeon-dynamic-clocks-fix.patch

More to the point, I suspect:
    xorg-x11-6.8.1-ati-radeon-dynamic-clocks-fix.patch

This is rather annoying because:
  -- I've tried another LCD monitor from Dell, but it behaves identically
  -- ATI will not replace the card, claiming it's a setup issue
  -- I don't like the analog interface as the image is crappy.

In other words, I really need to get to the bottom of this, and restore
the (clock?) behavior that was available with the original xorg RPM that
came with FC3 initially.


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.FC3.13.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Use an ATI Radeon 7000 card and a Dell 1905FP LCD
2. Update to xorg-x11-6.8.2-1.FC3.13.src.rpm
3. Start X


Actual Results:  Image starts flipping on/off, as if the monitor does not understand the signal.

Expected Results:  Image should just display.

Additional info:
Comment 1 Mike A. Harris 2005-06-21 12:42:54 EDT
If you disable DRI, by commenting out the 'Load "dri"' line in the xorg.conf
file, and then restart the X server, is the problem still reproduceable?

Please attach your X server config file, and a log file from the server
started with DRI, and another without DRI.

Setting status to "NEEDINFO", and awaiting requested data.
Comment 2 Dimi Paun 2005-06-24 12:01:51 EDT
No, without DRI it works just fine.

I've attached the xorg.conf and the Xorg.0.log for the non-DRI case.
I'll add the ones with DRI later on today.
Comment 3 Dimi Paun 2005-06-24 12:11:04 EDT
Created attachment 115941 [details]
X configuration file *without* DRI
Comment 4 Dimi Paun 2005-06-24 12:11:36 EDT
Created attachment 115942 [details]
X logs *without* DRI
Comment 5 Mike A. Harris 2006-01-17 19:59:58 EST
Fedora Core 3 has been transferred to the Fedora Legacy project, which will
be handling security related issues only.

DRI is known to be unstable on Radeon 7000 hardware in X.Org X11 6.8.x, and
should be disabled.  Users who continue to experience DRI related hangs on
Radeon 7000 hardware should upgrade to Fedora Core 4 and update to the latest
packages.  If the problems still persist, it is recommended to update to
Fedora Core 5 test2 which was just released, or to a newer version if
available.  If the issue still exists in X11R7, which is included in the
latest Fedora Core 5 test2 release, then users are encouraged to report
the problem to X.Org bugzilla located at http://bugs.freedesktop.org to
ensure the upstream developers are aware of the problem, and can diagnose
it for a future update.

Setting status to "RAWHIDE".

Note You need to log in before you can comment on or make changes to this bug.