Bug 160283 - r8169 network dies under high load
r8169 network dies under high load
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 00:12 EDT by Dave Theodore
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 14:38:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Theodore 2005-06-14 00:12:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I am attempting to copy a large amount of data (~200gb) and after 30-40 seconds, the network completely dies and nothing is logged in /var/log/messages or printed on the console.  A simple ifdown and ifup returns it to normal operation for another 30-40 seconds and the process repeats.  I have tried many different methods to copy this data, such as scp, rsync over nfs, http and ftp and all produce the same result.  The disk that is being copied to is a usb2 attached storage device.  The motherboard is Intel i440LX with dial P3 800mhz cpus and the Gig-e card is Airlink AGIGA32PCI.








Version-Release number of selected component (if applicable):
2.6.11-1.27_FC3smp

How reproducible:
Always

Steps to Reproduce:
1. Begin copying large file across the network using your favorite network protocol.  This is a gigabit card, so you will need 2 machines with gigabit and a gig switch to reproduce this.
2. Wait 30-40 seconds.
3. ifdown the interface and ifup again to see it fail again
  

Additional info:

#lspci
00:00.0 Host bridge: Intel Corp. 440GX - 82443GX Host bridge
00:01.0 PCI bridge: Intel Corp. 440GX - 82443GX AGP bridge
00:09.0 PCI bridge: Intel Corp. 80960RP [i960 RP Microprocessor/Bridge] (rev 03)
00:09.1 RAID bus controller: Mylex Corporation DAC960PG (rev 03)
00:0b.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controlle)
00:0b.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controlle)
00:0b.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 63)
00:0b.3 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller )
00:0c.0 SCSI storage controller: Adaptec AIC-7896U2/7897U2
00:0c.1 SCSI storage controller: Adaptec AIC-7896U2/7897U2
00:0e.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
00:12.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:12.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:12.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:12.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:14.0 VGA compatible controller: Cirrus Logic GD 5480 (rev 23)
01:0f.0 PCI bridge: Digital Equipment Corporation DECchip 21150 (rev 06)
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit E)
#

# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 796.513
cache size      : 256 KB
physical id     : 0
siblings        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pate
bogomips        : 1572.86

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 796.513
cache size      : 256 KB
physical id     : 0
siblings        : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pate
bogomips        : 1589.24
#

# lsmod
Module                  Size  Used by
nfs                   195625  1
lockd                  64233  2 nfs
vfat                   17217  1
fat                    43357  1 vfat
usb_storage            69257  1
md5                     8129  1
ipv6                  259681  14
parport_pc             31109  0
lp                     16201  0
parport                38793  2 parport_pc,lp
autofs4                22597  1
sunrpc                138885  4 nfs,lockd
ipt_REJECT             11073  1
ipt_state               5825  6
ip_conntrack           45481  1 ipt_state
iptable_filter          6849  1
ip_tables              25025  3 ipt_REJECT,ipt_state,iptable_filter
dm_mod                 60741  0
ohci1394               37849  0
ieee1394              308217  1 ohci1394
ehci_hcd               37197  0
uhci_hcd               35289  0
i2c_piix4              12497  0
i2c_core               25665  1 i2c_piix4
e100                   39105  0
mii                     8897  1 e100
r8169                  29901  0
aic7xxx               171897  0
ext3                  131401  5
jbd                    61401  1 ext3
DAC960                 74601  7
sd_mod                 22337  2
scsi_mod              129801  3 usb_storage,aic7xxx,sd_mod
#

# cat /proc/net/dev
Inter-|   Receive                                                |  Transmit
 face |bytes    packets errs drop fifo frame compressed multicast|bytes    packd
    lo:   15971      94    0    0    0     0          0         0    15971     0
  eth0:2751647633 1915271    0    0    0     0          0         0 133722542 10
  eth1:       0       0    0    0    0     0          0         0        0     0
  sit0:       0       0    0    0    0     0          0         0        0     0
#
Comment 1 John W. Linville 2005-07-06 11:12:40 EDT
I have test kernels w/ an r8169 update available here: 
 
   http://people.redhat.com/linville/kernels/fc3/ 
 
Let's start by giving those a try to see if they help the problem you are 
seeing.  Please post your results here...thanks! 
Comment 2 Dave Jones 2005-07-15 14:32:00 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 John W. Linville 2005-09-16 14:37:55 EDT
Closed due to lack of response.  Please re-open when the requested test 
results become available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.