Bug 160288 - slapd not starting with /tmp mounted as noexec
slapd not starting with /tmp mounted as noexec
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 03:36 EDT by Michael Fladischer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 07:51:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Fladischer 2005-06-14 03:36:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
I have my /tmp mounted on ah separate partition using the noexec option for security reasons. Since FC4 the start-up script /etc/rc.d/init.d/ldap creates a temporary wrapper-file in /tmp and executes this to start the slapd-daemon. Due to the noexec option this file cannot be executed.

Version-Release number of selected component (if applicable):
openldap-servers-2.2.23-5

How reproducible:
Always

Steps to Reproduce:
1. Mount /tmp using the noexec option
2. Run `service ldap start`
3.
  

Actual Results:  sldapd did not start.

Expected Results:  slapd starts.

Additional info:
Comment 1 Christian Iseli 2007-01-22 06:05:17 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 2 Jan Safranek 2007-06-08 07:51:59 EDT
Fixed in openldap-2.3.34-3.fc8 - no script is created.

Note You need to log in before you can comment on or make changes to this bug.