Bug 16029 - showpartial fails
Summary: showpartial fails
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metamail   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-11 20:54 UTC by Göran Uddeborg
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 18:14:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sugggested changes (1.36 KB, patch)
2000-08-11 20:55 UTC, Göran Uddeborg
no flags Details | Diff

Description Göran Uddeborg 2000-08-11 20:54:18 UTC
The showpartial script, called when applying metamail to a message/partial
message, fails to recreate the complete message.

1. When being called, it always prints an error message:
    tr: invalid backslash escape at end of string

2. After receiving all parts, it fails when trying to collect them:

    ---Executing: showpartial
    tr: invalid backslash escape at end of string
    cat:  1 2 3 4 5: No such file or directory
    rm: cannot remove ` 1 2 3 4 5': No such file or directory
    All parts of this 5-part message have now been read.
    metamail: Could not find end of mail headers.
    WARNING: To save space, the full file is now being deleted.
    You will have to read all 5 parts again to see the full message again.
    rmdir: /tmp/m-prts-gvran: Directory not empty
    metamail: Could not find end of mail headers.
    Exit 255

The second problem seems to be caused by the "ohnonotagain" (:-) patch
quoting a bit too much.  The $list variable is a sequence of numbers (1 2 3
...).  It won't contain any strange characters so it won't need quoting,
and the effect is to interpreting what is supposed to be a list of files as
a single file name with spaces.

See the enclosed patch for details.

Comment 1 Göran Uddeborg 2000-08-11 20:55:32 UTC
Created attachment 2415 [details]
Sugggested changes

Comment 2 Göran Uddeborg 2000-08-13 19:44:30 UTC
The same problem still exist in the pinstripe version of metamail: 2.7-25

Comment 3 Preston Brown 2001-02-01 18:14:54 UTC
fixed in 2.7-26 and later.  Thank you very much for the patch.


Note You need to log in before you can comment on or make changes to this bug.