Bug 160298 - After updating from FC2 to FC4 iiimf stops working
After updating from FC2 to FC4 iiimf stops working
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 04:14 EDT by ryuhei yokokawa
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 07:35:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the upgrade log from FC2 to FC4 (autogenerated probably by anaconda) (124.92 KB, text/plain)
2005-06-14 04:44 EDT, ryuhei yokokawa
no flags Details
anaconda config log (15.12 KB, text/plain)
2005-06-15 02:51 EDT, ryuhei yokokawa
no flags Details

  None (edit)
Description ryuhei yokokawa 2005-06-14 04:14:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
When upgrading from one version of FC to another (whether using netboot or the CDs), the iiimf always becomes weird.  I can not add an input method on GNOME using the IM-switcher application.  I want to type in Japanese but I cannot add the input method because it is not listed.  When I upgraded from FC2 to FC3 on my x86_64 laptop, this has happened (I just thought that that was a glitch that happened once) however, this happened again with another machine upgrading from FC2 to FC4.  I was not sure where to point to (whether to bugzilla anaconda or iiimf) but I chose iiimf.

Version-Release number of selected component (if applicable):
iiimf-le-canna-12.2-4

How reproducible:
Sometimes

Steps to Reproduce:
1.Have a FC2, or FC3 system with a functional iiimf installation.
2.Upgrade using whatever means (netboot, CDs, etc) to FC4.
3.Try to use the IM-switcher in GNOME but find that there are no other languages that can be used and also find that you can't use "SHIFT + SPACE" to change to Japanese mode

Actual Results:  IIIMF does not get upgraded correctly

Expected Results:  IIIMF should get upgraded correctly and should be usable

Additional info:

I also did a "rpm -qa | grep iiim" and found that there were multiple versions installed.  I tried to solve this but only ended up with more mess.  Here is the output from the above command:
iiimf-gtk-11.4-46.1.svn1587
iiimf-x-12.2-4
iiimf-libs-12.2-4
iiimf-gtk-12.2-4
iiimf-docs-12.2-4
iiimf-libs-devel-12.2-4
iiimf-gnome-im-switcher-12.2-4
iiimf-server-12.2-4
iiimf-server-11.4-46.1.svn1587
iiimf-le-canna-12.2-4
Comment 1 ryuhei yokokawa 2005-06-14 04:44:12 EDT
Created attachment 115387 [details]
the upgrade log from FC2 to FC4 (autogenerated probably by anaconda)
Comment 2 ryuhei yokokawa 2005-06-14 04:58:11 EDT
I've fixed this problem by uninstalling the whole iiimf set(rpm -e
iiimf-blahblah) , then reinstalling the whole set again.  However, this still
leaves Fedora with the problem since not all users are able to use the terminal
or understand how to fix the problem.
Comment 3 Akira TAGOH 2005-06-14 08:45:07 EDT
Is there an anaconda log from FC3 to FC4?
Comment 4 ryuhei yokokawa 2005-06-15 02:51:10 EDT
Created attachment 115455 [details]
anaconda config log

anaconda log
Comment 5 Gerald Cox 2005-06-16 00:48:20 EDT
Can you post the commands needed to correct this.  Thanks!
Comment 6 ryuhei yokokawa 2005-06-16 04:32:12 EDT
Well, I'm not sure if this will help you, but the problem my computer had was
with the fact that multiple version of some of the iiimf files were installed.
so here is basically what I did:

1. This tells you which iiimf files are installed on the computer.
rpm -qa | grep iiimf 

2. Now, you need to uninstall *all* of iiimf RPMS that were listed by the last
command. keep on doing this until all of it is gone. ex:
rpm -e iiimf-blah-blah.arch.rpm 

3. Should it spit out any errors about the anything, just keep on trying by
adding "--nodeps" to the end of the last command. ex:
rpm -e iiimf-blah-blah.arch.rpm  --nodeps

4. If it says it cant find a file of somesort that it needs for the uninstall,
fake it and just do this command: (this is not recommended but I was sort of
desparate to make it work for my parents)
touch file-thats-missing

5. If all or almost all of it is out of your system (I couldn't get one of the
iiimf rpms uninstalled myself), you can now reinstall the whole iiimf rpm set
off of the FC4 CD. (If you did a net install, you obviously need to get it from
fedora.redhat.com or the mirrors)

6. If this couldn't help you or if it mess it up to be worse...  I'm sorry.
Comment 7 Akira TAGOH 2005-06-16 06:04:50 EDT
(In reply to comment #4)
> Created an attachment (id=115455) [edit]
> anaconda config log
> 
> anaconda log

Sorry, I meant similar log you attached at comment #1. it looks like no contains
the word, "iiimf" at all.  What I want to know is that there was any errors
during the installation time. and what about the result of rpm -qa | grep iiimf
on FC3->FC4 box as well?
Comment 8 Akira TAGOH 2005-09-28 07:35:02 EDT
Since there are insufficient details provided in this report fur us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproducible anymore.
Please reopen this with the details if this issue is still reproducible.

Thanks

Note You need to log in before you can comment on or make changes to this bug.